Bug 682474 - qt 1:4.7.1-17.fc14 causes kmail composer lockup
qt 1:4.7.1-17.fc14 causes kmail composer lockup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-05 16:27 EST by Eli
Modified: 2011-06-03 13:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt-4.7.2-8.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-03 13:33:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eli 2011-03-05 16:27:56 EST
Description of problem:
qt 1:4.7.1-17.fc14 appears to cause kmail to lockup when you are trying to compose an email.  The result is that I cannot send email.

Version-Release number of selected component (if applicable):
qt 1:4.7.1-17.fc14
(and kdepim-4.4.10-1.fc14.i686)

How reproducible:
every time, though the timing of lockup is variable.

Steps to Reproduce:
1. start kmail
2. create a new email
3. spend some time composing an email, or just attempt to send the email
  
Actual results:
kmail locks up and does not respond to mouse clicks.  When the cursor passes over the text edit area for the email being composed, it vanishes.

Expected results:
I expected to be able to create and send email.

Additional info:
I was able to work around this with Kevin_Kofler's help.  I downgraded qt (and its subpackages, and qt-sqlite) to 4.7.1-7 using http://kojipkgs.fedoraproject.org/packages/qt/4.7.1/7.fc14/i686/qt-4.7.1-7.fc14.i686.rpm and related files.
After logging out of KDE and back in, I could once again compose email messages.

The lockup would occur after I'd been typing for a while, and possibly alt-tabbing to other applications while I was composing an email.  Sometimes I could finish typing the email (such as by making a very short test message), and then hitting Ctrl-Enter to send the message would trigger the lockup.  Since the test message I was doing was to an address for which I had encryption configured, the next step was for kmail to prompt for my passphrase.  Therefore I don't think anything in the network or transport side of things plays a part in this bug.

When kmail locked up, I would click on the [X] to close it, and would shortly be prompted to terminate the non-responding application.

On my currently working system:
$ rpm -qa | grep -e "qt.*-4.7.1"
qt-webkit-4.7.1-7.fc14.i686
qt-4.7.1-7.fc14.i686
qt-debuginfo-4.7.1-7.fc14.i686
qt-mysql-4.7.1-7.fc14.i686
qt-x11-4.7.1-7.fc14.i686
qt-devel-4.7.1-7.fc14.i686
qt-sqlite-4.7.1-7.fc14.i686

This is a Dell XPS M1330 laptop.

If I can do anything to assist in debugging this, email me at elicarter@retracile.net, or look for me as retracile on freenode.
Comment 1 Kevin Kofler 2011-03-05 19:03:22 EST
I suspect that it's the QTextBrowser regression fixes which caused yet another regression. (Grrr, I wonder if we should just revert the whole thing to the 4.7.0 code before the "performance optimization" which broke everything, with patch on top of patch fixing regressions and causing more. :-( ) We're going to have a 4.7.2 build to test soon, but I'm not sure it'll help. The patches in 4.7.1-17 are from what has since become 4.7.2.
Comment 2 Rex Dieter 2011-06-03 11:06:53 EDT
Is this still a problem or reproducible with latest updates?
Comment 3 Eli 2011-06-03 12:56:11 EDT
I have been on qt-4.7.2-8.fc14.i686 since Apr 23, 2011, and have not been having this problem any more.

Thanks!
Comment 4 Rex Dieter 2011-06-03 13:33:42 EDT
Excellent!

Note You need to log in before you can comment on or make changes to this bug.