Bug 682491 - Obsoletes for old plugins
Summary: Obsoletes for old plugins
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
(Show other bugs)
Version: 15
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Christoph Wickert
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F15Blocker-xfce
TreeView+ depends on / blocked
 
Reported: 2011-03-06 02:19 UTC by Christoph Wickert
Modified: 2011-03-13 04:44 UTC (History)
3 users (show)

Fixed In Version: Thunar-1.2.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-13 04:43:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Wickert 2011-03-06 02:19:06 UTC
Description of problem:
In order to provide a smooth upgrade to Xfce 4.8, a couple of plugins need to be obsoleted by xfce4-panel:

* xfce-volstatus-icon: dead upstream and uses HAL, but I might revive it nevertheless because I figured that porting to exo-1 is not that difficult.

* xfce4-stopwatch-plugin: dead upstream and does not work with xfce4-panel >= 4.7.

* xfce4-xfapplet-plugin: Only handles the old bonobo-based applets but not the new dbus based ones (bug 650073). With gnome-shell there is not much future for panel applets anyway.

The rest should be ok, I just fixed xfce4-cddrive-plugin and xfce4-mpc-plugin.

There is no need for immediate action here, lets just track this for now and sort it out until beta.

Comment 1 Christoph Wickert 2011-03-06 03:12:54 UTC
BTW: I'm afraid we also need Thunar have obsolete thunar-shares-plugin. I can make it build against the new Thunar, but it would need to be ported from thunar-vfs to gvfs to work. Not trivial.

Comment 2 Kevin Fenzi 2011-03-06 17:50:51 UTC
ok. I'd say we should add them sooner rather than later... and see if they all look good before beta.

Comment 3 Fedora Update System 2011-03-08 18:11:49 UTC
xfce4-panel-4.8.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-panel-4.8.2-2.fc15

Comment 4 Fedora Update System 2011-03-09 02:52:30 UTC
Thunar-1.2.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/Thunar-1.2.1-3.fc15

Comment 5 Fedora Update System 2011-03-13 04:43:20 UTC
xfce4-panel-4.8.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-03-13 04:44:05 UTC
Thunar-1.2.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.