Bug 682506 - Do not capture video
Do not capture video
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-06 04:09 EST by MERCIER Jonathan
Modified: 2012-01-05 06:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-05 06:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MERCIER Jonathan 2011-03-06 04:09:41 EST
Cheese capture video only when i click under effect button, after this it is diplay all effect availlable with preview on some preview effect i can see me. Example no Effect i choose this one and after cheese take any capture i see black screen.

cheese output:

$ cheese
** Message: cheese-effects-manager.vala:84: Found Bulge (bulge)
** Message: cheese-effects-manager.vala:84: Found Vertigo (vertigotv)
** Message: cheese-effects-manager.vala:84: Found Noir/Blanc (videobalance saturation=0)
** Message: cheese-effects-manager.vala:84: Found Waveform (revtv)
** Message: cheese-effects-manager.vala:84: Found Sepia (coloreffects preset=sepia)
** Message: cheese-effects-manager.vala:84: Found Edge (edgetv)
** Message: cheese-effects-manager.vala:84: Found Optical Illusion (optv)
** Message: cheese-effects-manager.vala:84: Found Dice (dicetv)
** Message: cheese-effects-manager.vala:84: Found Shagadelic (shagadelictv)
** Message: cheese-effects-manager.vala:84: Found Radioactive (radioactv)
** Message: cheese-effects-manager.vala:84: Found Invertion (frei0r-filter-invert0r)
** Message: cheese-effects-manager.vala:84: Found Kung-Fu (streaktv)
** Message: cheese-effects-manager.vala:84: Found Mirror (mirror)
** Message: cheese-effects-manager.vala:84: Found Mauve (videobalance saturation=1.5 hue=+0.5)
** Message: cheese-effects-manager.vala:84: Found Square (square)
** Message: cheese-effects-manager.vala:84: Found Heat (coloreffects preset=heat)
** Message: cheese-effects-manager.vala:84: Found Sobel (frei0r-filter-sobel)
** Message: cheese-effects-manager.vala:84: Found Kaleidoscope (kaleidoscope)
** Message: cheese-effects-manager.vala:84: Found X-Ray (coloreffects preset=xray)
** Message: cheese-effects-manager.vala:84: Found Distortion (frei0r-filter-distort0r)
** Message: cheese-effects-manager.vala:84: Found Stretch (stretch)
** Message: cheese-effects-manager.vala:84: Found Pinch (pinch)
** Message: cheese-effects-manager.vala:84: Found Historical (videobalance saturation=0 ! agingtv)
** Message: cheese-effects-manager.vala:84: Found Che Guevara (frei0r-filter-twolay0r)
** Message: cheese-effects-manager.vala:84: Found Twirl (twirl)
** Message: cheese-effects-manager.vala:84: Found Time delay (frei0r-filter-delay0r delaytime=5)
** Message: cheese-effects-manager.vala:84: Found Cartoon (frei0r-filter-cartoon)
** Message: cheese-effects-manager.vala:84: Found Saturation (videobalance saturation=2)
** Message: cheese-effects-manager.vala:84: Found Hulk (videobalance saturation=1.5 hue=-0.5)
** Message: cheese-effects-manager.vala:84: Found Chrome (frei0r-filter-color-distance)
** Message: cheese-effects-manager.vala:84: Found Quark (quarktv)
** Message: cheese-effects-manager.vala:84: Found Ripple (rippletv)
** Message: cheese-effects-manager.vala:84: Found Warp (warptv)
** (cheese:30139): WARNING **: Error with effect filter Cartoon. Ignored
(cheese:30139): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
** (cheese:30139): WARNING **: Error with effect filter Che Guevara. Ignored
(cheese:30139): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
** (cheese:30139): WARNING **: Error with effect filter Chrome. Ignored
(cheese:30139): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
** (cheese:30139): WARNING **: Error with effect filter Distortion. Ignored
(cheese:30139): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
** (cheese:30139): WARNING **: Internal data flow problem.
** (cheese:30139): WARNING **: Internal data flow problem.
** (cheese:30139): WARNING **: Internal data flow problem.
** (cheese:30139): WARNING **: Internal data flow problem.
** (cheese:30139): WARNING **: Internal data flow problem.
Comment 1 MERCIER Jonathan 2011-03-08 05:11:26 EST
fix smolt link:
http://www.smolts.org/client/show/pub_4c872f19-e514-498c-ad98-32d2613cc03d
Comment 2 MERCIER Jonathan 2011-03-24 09:30:52 EDT
ping
Comment 3 MERCIER Jonathan 2011-03-27 19:04:55 EDT
latest update fix a litle the problem, no on main window chesse show capture but is in black & white. In effect window cheese dislay capture video with color!
Comment 4 Sitsofe Wheeler 2011-03-28 17:00:28 EDT
Do things look normal if you set the Contrast and Saturation to the middle in the preferences?
Comment 5 Jason Montleon 2011-06-02 11:16:58 EDT
I am seeing  similar problem with cheese though no amount of playing with contrast, saturation, brightness, effects and so on. is getting me a visible picture.

If I use vlc to capture video from /dev/video0 using Video for Linux 2 it captures fine, but cheese just gives me a black screen.

Device is: Bus 001 Device 007: ID 05ac:8501 Apple, Inc. Built-in iSight [Micron]


If I start cheese from the shell I see:
.
.
.
** (cheese:2118): WARNING **: Got unexpected frame size of 153600 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262200 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
** (cheese:2118): WARNING **: Got unexpected frame size of 262144 instead of 614400.
.
.
.
** (cheese:2118): WARNING **: Internal data flow error.
Comment 6 Jason Montleon 2011-06-05 00:12:28 EDT
It looks like this was introduced with some changes made in gstreamer-plugins-good going from 0.10.26 -> 0.10.27 in sys/v4l2/gstv4l2object.c

I downgraded to gstreamer-plugins-good-0.10.26-1.fc14.x86_64.rpm and everything worked fine, so I built a custom 0.10.27 and saw that things broke. I was able to get it working again by commenting out a few lines.

I'm now successfully using gstreamer-plugins-good-0.10.29-1.fc15.x86_64.rpm with the following change:

diff -uNr gst-plugins-good-0.10.29/sys/v4l2/gstv4l2object.c gst-plugins-good-0.10.29-fixed/sys/v4l2/gstv4l2object.c
--- gst-plugins-good-0.10.29/sys/v4l2/gstv4l2object.c	2011-03-08 06:34:55.000000000 -0500
+++ gst-plugins-good-0.10.29-fixed/sys/v4l2/gstv4l2object.c	2011-06-04 23:59:31.040616435 -0400
@@ -1504,9 +1504,9 @@
   gint int_height = height;
 
   /* interlaced detection using VIDIOC_TRY/S_FMT */
-  if (!gst_v4l2_object_get_nearest_size (v4l2object, pixelformat,
-          &int_width, &int_height, &interlaced))
-    return NULL;
+  //if (!gst_v4l2_object_get_nearest_size (v4l2object, pixelformat,
+  //        &int_width, &int_height, &interlaced))
+  //  return NULL;
 
   memset (&ival, 0, sizeof (struct v4l2_frmivalenum));
   ival.index = 0;
Comment 8 MERCIER Jonathan 2011-07-29 17:14:31 EDT
for me it works now, if same for other closed the bug

Note You need to log in before you can comment on or make changes to this bug.