This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 682574 - crash in libpixman
crash in libpixman
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pixman (Show other bugs)
14
x86_64 All
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-06 15:47 EST by Account closed by user
Modified: 2011-05-21 15:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-21 15:37:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -nn (2.78 KB, text/plain)
2011-03-06 15:49 EST, Account closed by user
no flags Details
dmesg (55.81 KB, text/plain)
2011-03-06 15:49 EST, Account closed by user
no flags Details
Xorg.0.log (34.39 KB, text/plain)
2011-03-06 15:50 EST, Account closed by user
no flags Details
console-output.txt with ERRORS !! (1.58 KB, text/plain)
2011-03-06 15:52 EST, Account closed by user
no flags Details

  None (edit)
Description Account closed by user 2011-03-06 15:47:31 EST
kernel-2.6.35.11-83.fc14.x86_64
glibc-2.13-1.x86_64
pixman-0.18.4-1.fc14.x86_64
xorg-x11-drv-mouse-1.5.0-5.fc14.x86_64
xorg-x11-server-Xorg-1.9.4-1.fc14.x86_64
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14.x86_64
libdrm-2.4.22-1.fc14.x86_64
Comment 1 Account closed by user 2011-03-06 15:49:17 EST
Created attachment 482545 [details]
lspci -nn
Comment 2 Account closed by user 2011-03-06 15:49:49 EST
Created attachment 482546 [details]
dmesg
Comment 3 Account closed by user 2011-03-06 15:50:53 EST
Created attachment 482547 [details]
Xorg.0.log
Comment 4 Account closed by user 2011-03-06 15:52:38 EST
Created attachment 482548 [details]
console-output.txt with ERRORS !!
Comment 5 Matěj Cepl 2011-03-06 18:40:06 EST
CLosing as duplicate of bug 465884 for reasons explained there. Please, file a bug for each separate issue here (crashes etc.), message "EQ overflowing ..." etc. is so generic that it actually doesn't mean much.

*** This bug has been marked as a duplicate of bug 465884 ***
Comment 6 Matěj Cepl 2011-03-06 18:43:01 EST
Sorry, there is real crash here:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4a07b8]
1: /usr/bin/X (mieqEnqueue+0x1f4) [0x49fcb4]
2: /usr/bin/X (xf86PostButtonEventP+0xcf) [0x47cd4f]
3: /usr/bin/X (xf86PostButtonEvent+0xbe) [0x47ce7e]
4: /usr/lib64/xorg/modules/input/mouse_drv.so (0x7f31eaf48000+0x6316) [0x7f31eaf4e316]
5: /usr/lib64/xorg/modules/input/mouse_drv.so (0x7f31eaf48000+0x6b6c) [0x7f31eaf4eb6c]
6: /usr/lib64/xorg/modules/input/mouse_drv.so (0x7f31eaf48000+0x7050) [0x7f31eaf4f050]
7: /usr/bin/X (0x400000+0x6a5f7) [0x46a5f7]
8: /usr/bin/X (0x400000+0x118fb3) [0x518fb3]
9: /lib64/libc.so.6 (0x3395400000+0x33140) [0x3395433140]
10: /usr/lib64/libpixman-1.so.0 (0x33a1c00000+0x3cb66) [0x33a1c3cb66]
11: /usr/lib64/libpixman-1.so.0 (0x33a1c00000+0x307d3) [0x33a1c307d3]
12: /usr/lib64/libpixman-1.so.0 (pixman_image_composite32+0x103a) [0x33a1c3274a]
13: /usr/lib64/xorg/modules/libfb.so (fbComposite+0x220) [0x7f31ead3d710]
14: /usr/lib64/xorg/modules/libexa.so (0x7f31eab0d000+0x14140) [0x7f31eab21140]
15: /usr/lib64/xorg/modules/libexa.so (0x7f31eab0d000+0xffcc) [0x7f31eab1cfcc]
16: /usr/bin/X (0x400000+0xd6843) [0x4d6843]
17: /usr/bin/X (0x400000+0xcf559) [0x4cf559]
18: /usr/bin/X (0x400000+0x2d521) [0x42d521]
19: /usr/bin/X (0x400000+0x2157e) [0x42157e]
20: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x339541ee5d]
21: /usr/bin/X (0x400000+0x21129) [0x421129]
Comment 7 Walter Neumann 2011-04-14 12:28:14 EDT
Sorry -- I don't know how to tell if this is the same bug. Happens every couple of days. Started fairly recently. Kernel 2.6.35.12-88.fc14.i686, intel graphics. Let me know if I can be of help.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e834c]
1: /usr/bin/Xorg (mieqEnqueue+0x1b7) [0x80e7777]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xd2) [0x80c3122]
3: /usr/bin/Xorg (xf86PostMotionEvent+0x6b) [0x80c32bb]
4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f4000+0x2434) [0x7f6434]
5: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f4000+0x4768) [0x7f8768]
6: /usr/bin/Xorg (0x8047000+0x69950) [0x80b0950]
7: /usr/bin/Xorg (0x8047000+0x122b6c) [0x8169b6c]
8: (vdso) (__kernel_sigreturn+0x0) [0x2f8400]
9: /usr/bin/Xorg (0x8047000+0x5f900) [0x80a6900]
10: (vdso) (__kernel_sigreturn+0x0) [0x2f8400]
11: /lib/libc.so.6 (0xbf1000+0x77bd6) [0xc68bd6]
12: /lib/libc.so.6 (0xbf1000+0x9a13590) [0xa604590]
13: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
14: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
15: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
16: /usr/lib/libpixman-1.so.0 (0x946000+0x16504) [0x95c504]
17: /usr/lib/libpixman-1.so.0 (0x946000+0x39d41) [0x97fd41]
18: /usr/lib/libpixman-1.so.0 (pixman_image_composite32+0x10f2) [0x981b72]
19: /usr/lib/libpixman-1.so.0 (pixman_image_composite+0x8d) [0x981c3d]
20: /usr/lib/xorg/modules/libfb.so (fbComposite+0x1fe) [0xe4696e]
21: /usr/lib/xorg/modules/drivers/intel_drv.so (0x1db000+0x391bf) [0x2141bf]
22: /usr/lib/xorg/modules/drivers/intel_drv.so (0x1db000+0x35931) [0x210931]
23: /usr/bin/Xorg (0x8047000+0xdaef3) [0x8121ef3]
24: /usr/bin/Xorg (CompositePicture+0x233) [0x8116e13]
25: /usr/bin/Xorg (0x8047000+0xd39b9) [0x811a9b9]
26: /usr/bin/Xorg (0x8047000+0xd0624) [0x8117624]
27: /usr/bin/Xorg (0x8047000+0x28517) [0x806f517]
28: /usr/bin/Xorg (0x8047000+0x1b395) [0x8062395]
29: /lib/libc.so.6 (__libc_start_main+0xe6) [0xc07e36]
30: /usr/bin/Xorg (0x8047000+0x1af71) [0x8061f71]
Comment 8 Walter Neumann 2011-04-14 15:29:31 EDT
Additional info (it just happened again).
This is very recent -- probably since the kernel update to 2.6.35.12-88.fc14.i686, but I can't swear to that. There have been other recent updates, including Firefox. It looks to me like a kernel crash. I'd be glad of advice whether this should be posted as a separate bug and if so, to what component.

The trigger every time has been clicking to a page on Firefox. Most times (maybe every time) the home page button (my home page is not the problem, it hasn't changed in ages).

Xorg crashes, keyboard is nonresponsive (touchpad still moves the mouse). I can ssh in. Xorg is running at most of processor. Killing Xorg gets back to a login screen. 

Most recent backtrace:

Backtrace:                                                                         
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e834c]
1: /usr/bin/Xorg (mieqEnqueue+0x1b7) [0x80e7777]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xd2) [0x80c3122]
3: /usr/bin/Xorg (xf86PostMotionEvent+0x6b) [0x80c32bb]
4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x1a8000+0x2434) [0x1aa434]
5: /usr/lib/xorg/modules/input/synaptics_drv.so (0x1a8000+0x4768) [0x1ac768]
6: /usr/bin/Xorg (0x8047000+0x69950) [0x80b0950]
7: /usr/bin/Xorg (0x8047000+0x122b6c) [0x8169b6c]   
8: (vdso) (__kernel_sigreturn+0x0) [0x70d400]        
9: /usr/bin/Xorg (0x8047000+0x5f900) [0x80a6900]
10: (vdso) (__kernel_sigreturn+0x0) [0x70d400]
11: /usr/lib/libpixman-1.so.0 (0x946000+0x3c80) [0x949c80]
12: /usr/lib/libpixman-1.so.0 (0x946000+0x46565) [0x98c565]
13: /usr/lib/libpixman-1.so.0 (0x946000+0x157aa) [0x95b7aa]
14: /usr/lib/libpixman-1.so.0 (0x946000+0x39b50) [0x97fb50]
15: /usr/lib/libpixman-1.so.0 (pixman_image_composite32+0x10f2) [0x981b72]
16: /usr/lib/libpixman-1.so.0 (pixman_image_composite+0x8d) [0x981c3d]
17: /usr/lib/xorg/modules/libfb.so (fbComposite+0x1fe) [0x18996e]
18: /usr/lib/xorg/modules/drivers/intel_drv.so (0xf25000+0x391bf) [0xf5e1bf]
19: /usr/lib/xorg/modules/drivers/intel_drv.so (0xf25000+0x35931) [0xf5a931]
20: /usr/bin/Xorg (0x8047000+0xdaef3) [0x8121ef3]
21: /usr/bin/Xorg (CompositePicture+0x233) [0x8116e13]
22: /usr/bin/Xorg (0x8047000+0xd39b9) [0x811a9b9]
23: /usr/bin/Xorg (0x8047000+0xd0624) [0x8117624]
24: /usr/bin/Xorg (0x8047000+0x28517) [0x806f517] 
25: /usr/bin/Xorg (0x8047000+0x1b395) [0x8062395]
26: /lib/libc.so.6 (__libc_start_main+0xe6 [0xc07e36]
27: /usr/bin/Xorg (0x8047000+0x1af71) [0x8061f71] 
(In reply to comment #7)
> Sorry -- I don't know how to tell if this is the same bug. Happens every couple
> of days. Started fairly recently. Kernel 2.6.35.12-88.fc14.i686, intel
> graphics. Let me know if I can be of help.
> 
> [mi] EQ overflowing. The server is probably stuck in an infinite loop.
> 
> Backtrace:
> 0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e834c]
> 1: /usr/bin/Xorg (mieqEnqueue+0x1b7) [0x80e7777]
> 2: /usr/bin/Xorg (xf86PostMotionEventP+0xd2) [0x80c3122]
> 3: /usr/bin/Xorg (xf86PostMotionEvent+0x6b) [0x80c32bb]
> 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f4000+0x2434) [0x7f6434]
> 5: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f4000+0x4768) [0x7f8768]
> 6: /usr/bin/Xorg (0x8047000+0x69950) [0x80b0950]
> 7: /usr/bin/Xorg (0x8047000+0x122b6c) [0x8169b6c]
> 8: (vdso) (__kernel_sigreturn+0x0) [0x2f8400]
> 9: /usr/bin/Xorg (0x8047000+0x5f900) [0x80a6900]
> 10: (vdso) (__kernel_sigreturn+0x0) [0x2f8400]
> 11: /lib/libc.so.6 (0xbf1000+0x77bd6) [0xc68bd6]
> 12: /lib/libc.so.6 (0xbf1000+0x9a13590) [0xa604590]
> 13: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
> 14: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
> 15: /usr/lib/libpixman-1.so.0 (0x946000+0x16267) [0x95c267]
> 16: /usr/lib/libpixman-1.so.0 (0x946000+0x16504) [0x95c504]
> 17: /usr/lib/libpixman-1.so.0 (0x946000+0x39d41) [0x97fd41]
> 18: /usr/lib/libpixman-1.so.0 (pixman_image_composite32+0x10f2) [0x981b72]
> 19: /usr/lib/libpixman-1.so.0 (pixman_image_composite+0x8d) [0x981c3d]
> 20: /usr/lib/xorg/modules/libfb.so (fbComposite+0x1fe) [0xe4696e]
> 21: /usr/lib/xorg/modules/drivers/intel_drv.so (0x1db000+0x391bf) [0x2141bf]
> 22: /usr/lib/xorg/modules/drivers/intel_drv.so (0x1db000+0x35931) [0x210931]
> 23: /usr/bin/Xorg (0x8047000+0xdaef3) [0x8121ef3]
> 24: /usr/bin/Xorg (CompositePicture+0x233) [0x8116e13]
> 25: /usr/bin/Xorg (0x8047000+0xd39b9) [0x811a9b9]
> 26: /usr/bin/Xorg (0x8047000+0xd0624) [0x8117624]
> 27: /usr/bin/Xorg (0x8047000+0x28517) [0x806f517]
> 28: /usr/bin/Xorg (0x8047000+0x1b395) [0x8062395]
> 29: /lib/libc.so.6 (__libc_start_main+0xe6) [0xc07e36]
> 30: /usr/bin/Xorg (0x8047000+0x1af71) [0x8061f71]
Comment 9 Account closed by user 2011-05-21 15:37:10 EDT
nobody cares, closing...

Note You need to log in before you can comment on or make changes to this bug.