Bug 682584 - mail-notification-5.4-33.fc15.i686 won't start.
Summary: mail-notification-5.4-33.fc15.i686 won't start.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mail-notification
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-06 22:10 UTC by GoinEasy9
Modified: 2011-12-23 22:19 UTC (History)
3 users (show)

Fixed In Version: mail-notification-5.4-48.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-23 22:19:18 UTC
Type: ---


Attachments (Terms of Use)
mail-notification error png (11.56 KB, image/png)
2011-03-06 22:11 UTC, GoinEasy9
no flags Details
mail-notification gdb (6.89 KB, text/plain)
2011-03-06 22:34 UTC, GoinEasy9
no flags Details
console output (with mail-notification-5.4-45.fc16.x86_64 fresh install) (3.89 KB, text/plain)
2011-12-04 13:12 UTC, Michael Schwendt
no flags Details

Description GoinEasy9 2011-03-06 22:10:14 UTC
Description of problem: Fails to load after clicking menu icon


Version-Release number of selected component (if applicable):
mail-notification-5.4-33.fc15.i686

How reproducible: Click on menu icon


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:  Error says it wasn't installed properly.  I removed then reinstalled, same error.

Comment 1 GoinEasy9 2011-03-06 22:11:01 UTC
Created attachment 482555 [details]
mail-notification error png

Comment 2 GoinEasy9 2011-03-06 22:34:47 UTC
Created attachment 482557 [details]
mail-notification gdb

Comment 3 Erik van Pienbroek 2011-03-07 06:32:40 UTC
It looks like the GConf schemas weren't installed correctly. This is a fresh F15 installation right? I'll look into it ASAP

Comment 4 GoinEasy9 2011-03-08 02:56:44 UTC
Yes, it was a fresh install.  Thank You.

Comment 5 Erik van Pienbroek 2011-03-12 14:06:44 UTC
I just tried to reproduce this issue using a freshly installed F15-Alpha virtual machine (desktop spin) and mail-notification started just fine here. Did you use some other spin like the KDE one to install F15-Alpha ?

Comment 6 Erik van Pienbroek 2011-03-12 16:18:32 UTC
Just tried with the F15-Alpha-KDE spin and mail-notification seems to work fine with that as well..

Did you already try to run mail-notification after rebooting the machine?

Comment 7 GoinEasy9 2011-03-12 18:21:08 UTC
After applying the updates mail-notification now seems to be working.  It wasn't a KDE install, it was a straight up Gnome 3 install to HD.  Thanks for your attention.

Comment 8 Michael Schwendt 2011-12-04 09:32:36 UTC
Reproducible with mail-notification-5.4-45.fc16.x86_64

$ mail-notification 

** (mail-notification:4205): WARNING **: cannot find default value of configuration key "/apps/mail-notification/commands/new-mail/enabled"

and lots of others.

Comment 9 Michael Schwendt 2011-12-04 09:59:48 UTC
Apparently, a reboot made it work. This isn't normal for GConf.

You could update the RPM scriptlet sections:
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#GConf

Comment 10 Erik van Pienbroek 2011-12-04 12:15:32 UTC
Michael, thanks for the hint.

The mail-notification spec file already contains the required %post instructions to install the GConf2 schema, but for some reason this seems to got broken on recent Fedora releases.

The %post section of mail-notification.spec currently contains this:

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
/usr/bin/gconftool-2 --makefile-install-rule \
  %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :

This isn't the RPM macro which is mentioned in the packaging snippets, but looking at /etc/rpm/macros.gconf2 the exact same code is also executed when using the %gconf_schema_upgrade macro, so I think the real cause is somewhere else.

Were you using a complete clean Fedora installation before trying to install mail-notification? And what package groups/spin did you select/use during installation?

Comment 11 Michael Schwendt 2011-12-04 13:12:09 UTC
Created attachment 540322 [details]
console output (with mail-notification-5.4-45.fc16.x86_64 fresh install)

I'm using a normal GNOME Desktop install from DVD ISO image.

After uninstalling mail-notification package again, rebooting once more, reinstalling mail-notification package, the problem is reproducible. Next thing I'll try after submitting this comment is to log out and back in (as an alternative to rebooting).

Comment 12 Michael Schwendt 2011-12-04 13:15:09 UTC
After logging out and back in into GNOME Shell, a "Mail Notification Properties" window opened automatically, and afterwards the problem is gone.

Comment 13 Michael Schwendt 2011-12-04 13:23:03 UTC
kill -HUP $(pidof gconfd-2)   does not fix the issue, but killing gconfd-2 does.

Comment 14 Michael Schwendt 2011-12-04 13:37:47 UTC
Another test a few minutes after a fresh install of mail-notification, when it doesn't start:

  $ gconftool-2 --get /apps/mail-notification/commands/new-mail/enabled
  No value set for `/apps/mail-notification/commands/new-mail/enabled'

Then after relogin without touching/closing the open "Mail Notification Properties" window:

  $ gconftool-2 --get /apps/mail-notification/commands/new-mail/enabled
  false

Comment 15 Fedora Update System 2011-12-19 16:51:45 UTC
mail-notification-5.4-48.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mail-notification-5.4-48.fc16

Comment 16 Fedora Update System 2011-12-22 22:46:56 UTC
Package mail-notification-5.4-48.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mail-notification-5.4-48.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17330/mail-notification-5.4-48.fc16
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-12-23 22:19:18 UTC
mail-notification-5.4-48.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.