Bug 68260 - Using xine causes x server redraw glitch or problem
Using xine causes x server redraw glitch or problem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xine (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 13:38 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 08:48:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of the problem (375.78 KB, image/jpeg)
2002-07-08 13:39 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-08 13:38:22 EDT
Description of Problem:
During and after playback of a video with xine  I notice that my x-server no
longer always draws menus and parts of windows correctly. Menu items, text
labels and so on, are drawn with black rectangles. Some of these rectangles
disappear if you move the mouse over them, or select a value from the field.
however next time you activate the menu / window, the same problem will occur.

Version-Release number of selected component (if applicable):


How Reproducible:
Every time.

Steps to Reproduce:
1. load xine
2. play video
3. 

Actual Results:


Expected Results:
X server should continue to function normally.

Additional Information:
I am using a G550 DH card, running the standard mga driver that shipped with
limbo and the config generated by anaconda.

Only 2 menus seems affected: "Desktop Preferences", and "System Tools". Most
Gnome windows are also affected, by applications such as Mozilla seem unaffected.

The problem is not cured if you exit and then restart the X server. Only a full
reboot seems to cure the problem.
Comment 1 Need Real Name 2002-07-08 13:39:24 EDT
Created attachment 64289 [details]
Example of the problem
Comment 2 Need Real Name 2002-07-08 13:41:16 EDT
Playing videos in other video packages, eg MPEGs, ASFs does not exhibit the same
problem.
Comment 3 Need Real Name 2002-07-20 14:41:50 EDT
I think I've tracked down what causes this, not sure though...

It seems to be triggered if you manage to get two copies of xine running at the
same time. There seems to be an occasional bug either in the nautilus file
selector, or the startup in xine that doesn't check that a instance of xine is
already running and triggers a second copy. When this happens, the graphics go
all screwy as noted before.

Reboot is still the only option to cure it though.
Comment 4 Karsten Hopp 2004-01-27 08:48:30 EST
xine isn't part of any supported product from Red Hat anymore

Note You need to log in before you can comment on or make changes to this bug.