Bug 682667 - [Indic] Indian language fonts rendering fuzzy in gnome3
Summary: [Indic] Indian language fonts rendering fuzzy in gnome3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-07 08:10 UTC by Rajesh Ranjan
Modified: 2015-04-21 04:33 UTC (History)
10 users (show)

Fixed In Version: lohit-gujarati-fonts-2.4.5-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-08 05:16:44 UTC


Attachments (Terms of Use)
lohit-devanagari font shown on gedit (47.40 KB, image/png)
2011-03-07 08:10 UTC, Rajesh Ranjan
no flags Details
lohit-devanagari font shown on firefox (518.95 KB, image/png)
2011-03-07 08:11 UTC, Rajesh Ranjan
no flags Details
Gedit Screenshot with Yellow Mark (33.77 KB, image/png)
2011-03-07 08:45 UTC, A S Alam
no flags Details

Description Rajesh Ranjan 2011-03-07 08:10:09 UTC
Created attachment 482617 [details]
lohit-devanagari font shown on gedit

Description of problem:

The effect of font is detoriated from last version...probabably it is hinting problem. The chars appearing look fuzzier.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Rajesh Ranjan 2011-03-07 08:11:07 UTC
Created attachment 482618 [details]
lohit-devanagari font shown on firefox

Comment 2 A S Alam 2011-03-07 08:45:17 UTC
Created attachment 482626 [details]
Gedit Screenshot with Yellow Mark

Comment 3 Sweta Kothari 2011-03-07 09:34:04 UTC
It's same situation in Gujarati. it's appearing on most of the all applications (gedit, firefox, libreoffice, etc...), Please look into it.

Comment 4 Rajesh Ranjan 2011-03-07 10:37:37 UTC
Same problem of libreoffice exists.

Comment 5 Pravin Satpute 2011-03-24 08:42:27 UTC
yeah, its giving very bad rendering experience
looks like some problem from hinting side

i have not changed anything in lohit

Comment 6 Kevin Kofler 2011-03-24 11:54:58 UTC
Are the Lohit fonts partially hinted?

If so, Freetype will see that there is some hinting bytecode and try to use the bytecode interpreter. If the relevant characters are then not actually hinted, it will fail.

According to Freetype upstream, you should remove all hinting bytecode from the fonts if it's not complete. If Freetype sees that there's no hinting bytecode, it will now automatically fallback to the autohinter. (I got that fixed, see bug 547532.) But the patch doesn't help for partially hinted fonts, and Freetype upstream told me they don't want to support these anyway.

Comment 7 Nicolas Mailhot 2011-03-24 12:18:16 UTC
That's unfortunate, partially hinted fonts are a fact of life, any font with non-trivial coverage will always be a WIP hinting-side

Comment 8 Pravin Satpute 2011-03-25 06:06:01 UTC
unfortunately there are some hinting instructions in Lohit http://svn.fedorahosted.org/svn/lohit/trunk/devanagari/Lohit-Devanagari.sfd

see
TtTable: fpgm
.
.
EndTTInstrs

I quickly tried to remove this and test rendering initial results look good, i will build all lohit fonts removing hinting instructions.

thanks Kevin for quick comments

Lohit was never hinted intentionally but dunno from where these instructions came.

Comment 9 Pravin Satpute 2011-03-25 08:36:58 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2944549 scratch build for testing

Comment 10 Kevin Kofler 2011-03-25 10:12:26 UTC
I think we have other fonts affected by this too, e.g. our CJK fonts appear to be all partially hinted (in a useless way, i.e. none actually hints the CJK characters), we should probably file bugs against all the affected fonts.

Comment 11 Pravin Satpute 2011-03-29 08:46:06 UTC
scratch build for gujarati

http://koji.fedoraproject.org/koji/taskinfo?taskID=2956455

sweta please test and let me know, so i can build it

Comment 12 Sweta Kothari 2011-03-29 09:01:11 UTC
I have checked quickly, it looks ok from my side.

Comment 13 Fedora Update System 2011-03-30 06:25:26 UTC
lohit-gujarati-fonts-2.4.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-gujarati-fonts-2.4.5-1.fc15

Comment 14 A S Alam 2011-03-30 07:27:59 UTC
Hindi and Gujarati seems working fine. Can lohit-devanagari fonts can be build?

Comment 15 Pravin Satpute 2011-03-30 07:37:09 UTC
Yeah Sure, i am thinking to make upstream release of lohit devanagari will do that tomorrow

thanks for testing

Comment 16 Fedora Update System 2011-03-31 03:56:52 UTC
Package lohit-gujarati-fonts-2.4.5-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-gujarati-fonts-2.4.5-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/lohit-gujarati-fonts-2.4.5-1.fc15
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-03-31 06:32:55 UTC
lohit-devanagari-fonts-2.4.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.4.5-1.fc15

Comment 18 Fedora Update System 2011-04-15 21:54:30 UTC
lohit-devanagari-fonts-2.4.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-05-10 03:22:42 UTC
lohit-gujarati-fonts-2.4.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.