Bug 68271 - RFE: Alcatel SpeedTouch USB DSL modem support
RFE: Alcatel SpeedTouch USB DSL modem support
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://linux-usb.sourceforge.net/Spee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 15:47 EDT by Michel Alexandre Salim
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-04 22:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2002-07-08 15:48:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
My friend's computer has an Alcatel SpeedTouch USB modem that connects to the
Internet using a PPPoA connection; it is supported under Linux but not by
default, which makes for a real hassle when configuring.

Could support be added for the upcoming 8.0 release? The driver (and its
alternate) is open source; it does require some binary data from Alcatel though
(link provided on the page at the URL above).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Limbo on a computer with Alcatel SpeedTouch USB


Actual Results:  Modem not detected

Expected Results:  Modem detected, available for setup under first-time setup wizard

Additional info:

Alternate driver at http://benoit.papillault.free.fr/speedtouch/index.en.php3

Linux driver from Alcatel/Thomson at:
http://www.speedtouchdsl.com/support.htm
Comment 1 Alan Cox 2002-07-26 11:52:33 EDT
It requires a binary only management tool
Comment 2 Michel Alexandre Salim 2002-07-26 14:32:10 EDT
How about just PPPoA support, so it would be easier for users to compile the USB
drivers themselves?
Comment 3 Alex Hornby 2002-11-23 12:18:02 EST
This modem is also very common in the UK, as the major ISPs typically give it
away or offer it as an option with an ADSL broadband connection.

Adding support for the existing linux drivers from 
http://linux-usb.sourceforge.net/SpeedTouch/ to RedHat would make it much
easier for broadband users in the UK to switch to Linux - at the moment it takes
a _lot_ of configuration. 
Comment 4 Need Real Name 2003-03-25 08:16:07 EST
Maybe we get this in 9?

I hope so - most ADSL users use a speedtouch modem, and around half of 
broadband users use ADSL.
Comment 5 Alan Cox 2003-03-25 08:47:13 EST
Most newer UK broadband is using other products, generally the little ADSL
routers to ethernet. The speedtouch is tricky for 2.4 because it involves major
changes to layers like ATM. It is in the 2.6 base tree if I remenber rightly
however so things move slowly the right way
Comment 6 Tim Mortlock 2003-12-30 05:00:40 EST
Fedora includes an option for the SpeedTouch when you do a make 
menuconfig. However, enabeling this and recompiling has no effect. 
The main problem is the internet configuration wizard for xDSL will 
only see my ethernet port, not my USB modem...

I'm currently trying the Speedbundle open source drivers and as a 
newbie its causing me a BIG headache... I can see how this would 
deter many people from Linux as trying to get online is killing me...
Comment 7 Dave Jones 2004-01-04 22:33:29 EST
speedtch.o module is already compiled for Fedora, so you don't need to
recompile.

There won't be another RHL8 errata, so I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.