This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 68296 - Installer (Anaconda) doesn't give choice between KDM or GDM
Installer (Anaconda) doesn't give choice between KDM or GDM
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-08 18:08 EDT by Peter van Egdom
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 18:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-07-08 18:08:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
Previous versions of Red Hat Linux presented the user with
the choice of 'having a default desktop'.

(the choice was between KDE and GNOME resulting in either
 KDM as the default login-manager or GDM).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Linux
2. Look at the graphical configuration screen.
3.
	

Actual Results:  No choice between KDM / GDM.

Expected Results:  User should have had the choice between KDM or GDM.

Additional info:
Comment 1 Havoc Pennington 2002-07-08 18:29:13 EDT
We are working on trimming down the installer to have fewer choices that 
confuse people who are unfamiliar with the implementation technologies; KDE and
GNOME are somewhat confusing acronyms, and a choice people are asked to make
before they've even seen KDE or GNOME.

You can still change the default after you restart by editing
/etc/sysconfig/desktop, or per-user by running switchdesk. Or you could 
have a kickstart file modify /etc/sysconfig/desktop.
Comment 2 Nathan G. Grennan 2002-07-09 00:56:16 EDT
HP and his reduce choices in the name of confusion strikes again.
Comment 3 Need Real Name 2002-07-09 12:11:07 EDT
Three pluses go to the RH folks for integrating kde items into the gnome menu
heirarchy and vice versa this go 'round.

However, three strikes against for deleting the choice for KDE from setup.  I
don't mind you guys being gnome fanatics (much), but do leave folks a choice.

My suggestion FWIW is to make the choice a pulldown with gnome as the default. 
That will reduce the confusion plus give those of us that don't
eat-sleep-breath-**** gnome an option.
Comment 4 Nathan G. Grennan 2002-07-09 15:52:05 EDT
Intregrating KDE items into the Gnome menus is just a mess. You get 2-3 key
bindings, etc. You aren't sure what is for modifying Gnome settins and what is
used for modifiying KDE settings. It would probably be fine if it had seperate
KDE and Gnome settings menus, but combine the Gnome and KDE application listings
as long as you rename some of them with less generic titles.
Comment 5 Havoc Pennington 2002-07-09 16:03:45 EDT
There's no loss of choice, it's just not in the GUI in one place. It's easy to
change if you're the sort of user that understands these things. 

The menus will make a lot more sense once they're sorted out. Menu items that only 
affect KDE should not be visible in GNOME and vice versa.
Comment 6 Need Real Name 2002-07-10 00:00:22 EDT
You know, this pretty much tears it.  I'm a longtime linux user (with a 0.97
kernel tree and an old backup of SLS pre1.0 on 41 floppies to prove it), a user
of Redhat since the Mother's Day release, and a stockholder (though not with
enough shares that anyone would really notice).  I've put together Redhat
systems left and right including a P5-120 (fast x86 then) three machine cluster
that did email and general computing support for a 14,000+ student campus that
still relies on RH today.   I've put up with releases that didn't "quite" work,
strange support at times, and heaven knows what else asking little, giving out
what help I could, and contributing the odd patch or suggestion now and then. 
Bottom line, I've been around a while -- being no great contributor of much
besides longevity and brand loyalty.

But this gnome-centric bigotry does it for me.  Mandrake, Conectiva and other
distros certainly manage to support several environments without so-called
confusion.  Mandrake even so far as creating a configuration engine that
supports *both* Gnome and KDE.  This "my way or the highway" approach doesn't
impress me and reminds me way too much of a large campus in Redmond, Washington.
Comment 7 Havoc Pennington 2002-07-10 09:21:33 EDT
It has nothing to do with gnome-centricness. It has to do with the right user
interface. A reasonable UI does not make users choose between two unfamiliar
acronyms before they've even seen the operating system.

All this option does is toggle gdm/kdm; gdm doesn't look particularly "GTK"
anymore, it looks like a big image, and that's what we want people to see by
default.

Users who know what KDE and GNOME are aren't going to have a problem making a
3-character change to /etc/sysconfig/desktop, or choosing KDE when they log in
to their account, or running switchdesk.
Comment 8 Need Real Name 2002-07-10 18:40:59 EDT
No, a reasonable interface provides choices, adequate explainations and
illustrations, a good default choice, and prompting for the beginner.

Took an altogether embarrassing amount of time in my early years to realize
that. ;-)
Comment 9 Havoc Pennington 2002-07-10 19:09:06 EDT
People don't read explanations. They'd just make the thing more cluttered.
Any UI test demonstrates this quickly.

But you don't need theoretical arguments. The feature just isn't that useful
for traditional linux users when it's so easy to change after reboot.
And imagine an OS you've never used or read about, and you get this choice:

 Default blarg:
   ( ) YUTRO
   ( ) WOOZ

That's exactly what this feature was. It's silly.

Note You need to log in before you can comment on or make changes to this bug.