Bug 682979 - libguestfs incorrectly detects Red Hat desktop as 'redhat-based' instead of 'redhat'
libguestfs incorrectly detects Red Hat desktop as 'redhat-based' instead of '...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 677286 682980
  Show dependency treegraph
 
Reported: 2011-03-08 02:55 EST by Richard W.M. Jones
Modified: 2011-03-08 11:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 677286
Environment:
Last Closed: 2011-03-08 11:21:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-03-08 02:55:25 EST
+++ This bug was initially created as a clone of Bug #677286 +++

Description of problem:
convert rhel4u8 guest from esx to kvm (libvirt and rhevm) modprobe.conf is incorrect 
the network and storage driver are not virtio 

Version-Release number of selected component (if applicable):
virt-v2v-0.6.3-5.el5

libguestfs-1.2.7-1.el5.8

libguestfs-*-1.2.7-1.el5.8

libvirt-0.8.2-15.el5_6.1

febootstrap-2.6-1.el5.2

hivex-1.2.2-1.el5.1

augeas-libs-0.7.3-1.el5.1

virtio-win-1.0.1-2.52454.el5

RHEVM ic91

rhevh-5.6-8.1

How reproducible:
always

Steps to Reproduce:
1.# virt-v2v -ic esx://10.66.72.149/?no_verify=1 -op esx -n default ESX4.0-rhel4u8-32b

unknown filesystem /dev/hdc
unknown filesystem /dev/fd0
virt-v2v: No capability in config matches os='linux' name='virtio' distro='redhat-based'
virt-v2v: ESX4.0-rhel4u8-32b configured without virtio drivers

2.check the modprobe.conf
# cat /etc/modprobe.conf 
alias eth0 e1000 

  
Actual results:
alias eth0 e1000 


Expected results:
alias eth0 virtio
  

Additional info:
esx3.5 esx4.0 and esx4.1 all can reproduce this bug 
/boot/devive.map is not update  
if the guest is rhel4u9 ,everything is fine .

--- Additional comment from whuang@redhat.com on 2011-02-14 04:20:44 EST ---

Created attachment 478589 [details]
ESX4.1-RHEL4.8-64b.log

--- Additional comment from whuang@redhat.com on 2011-02-14 05:21:01 EST ---

set Priority: low	Severity:low

sorry Matt , We install the wrong guest(redhat desktop 4u8 ) ,the "Red Hat Enterprise Linux 4u8" is fine ,but it is also a bug .

--- Additional comment from mbooth@redhat.com on 2011-02-14 06:12:09 EST ---

Note from the error message that the guest OS has been detected as 'redhat-based', which we don't have any config for:

virt-v2v: No capability in config matches os='linux' name='virtio'
distro='redhat-based'

This seems to be an oversight in libguestfs's OS detection. I've moved this to to libguestfs and updated the title.

--- Additional comment from rjones@redhat.com on 2011-03-07 08:01:07 EST ---

Huang, could you please let us know the contents of the file:

  /etc/redhat-release

from *inside* the guest?

--- Additional comment from yupzhang@redhat.com on 2011-03-07 22:07:13 EST ---

From guest:
#cat /etc/redhat-release
Red Hat Desktop release 4 (Nahant Update 8)

--- Additional comment from rjones@redhat.com on 2011-03-08 02:54:19 EST ---

I see the problem.  Cloning this bug for upstream and 6.2.
Comment 1 Richard W.M. Jones 2011-03-08 03:13:49 EST
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2011-March/msg00029.html

Note You need to log in before you can comment on or make changes to this bug.