Bug 682987 - Machine Type defaults to rhel5.4.0 on RHEL5.6 host
Machine Type defaults to rhel5.4.0 on RHEL5.6 host
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Ronen Hod
Virtualization Bugs
: Reopened
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-03-08 03:38 EST by Mike Cao
Modified: 2015-11-22 22:34 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-01 09:51:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2011-03-08 03:38:28 EST
Description of problem:
Machine Type defaults to rhel5.4.0  on RHEL5.6 host

Version-Release number of selected component (if applicable):
# uname -r
2.6.18-238.el5
# rpm -q kvm
kvm-83-227.el5

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M ?
2.
3.
  
Actual results:
Supported machines are:
pc         RHEL 5.4.0 PC (alias of rhel5.4.0)
rhel5.4.0  RHEL 5.4.0 PC (default)
rhel5.4.4  RHEL 5.4.4 PC
rhel5.5.0  RHEL 5.5.0 PC
rhel5.6.0  RHEL 5.6.0 PC

Expected results:
should change rhel5.6.0 as default value.

Additional info:
Comment 1 juzhang 2011-05-10 01:01:34 EDT
Hit the same issue on rhel5.7 with kvm-83-232.el5. mark qa_ack+

#/usr/libexec/qemu-kvm -M ?
Supported machines are:
pc         RHEL 5.4.0 PC (alias of rhel5.4.0)
rhel5.4.0  RHEL 5.4.0 PC (default)
rhel5.4.4  RHEL 5.4.4 PC
rhel5.5.0  RHEL 5.5.0 PC
rhel5.6.0  RHEL 5.6.0 PC
Comment 2 john cooper 2011-05-17 13:05:29 EDT

*** This bug has been marked as a duplicate of bug 699347 ***
Comment 3 Mike Cao 2011-07-05 23:35:11 EDT
Reopen this bug ,

I still think we need use -M rhel5.6.0 as default on rhel5.6.0+ hosts.
Comment 5 Dor Laor 2011-07-06 09:37:47 EDT
(In reply to comment #3)
> Reopen this bug ,
> 
> I still think we need use -M rhel5.6.0 as default on rhel5.6.0+ hosts.

That's wrong. We do not change the default on minor releases.
Anyone wishes to use another machine type should just use the right flag.
Comment 6 Mike Cao 2011-12-08 03:33:54 EST
Reopen this bug .based on following reasons 

1.We hit lots of timer device issues if we forgot to add -M rhel5.6.0
2.qemu-kvm in RHEL6.x always change the default machine type to the newest one
Comment 8 Dor Laor 2012-02-01 09:51:39 EST
(In reply to comment #6)
> Reopen this bug .based on following reasons 
> 
> 1.We hit lots of timer device issues if we forgot to add -M rhel5.6.0

Check comment #5 and remember to add it

> 2.qemu-kvm in RHEL6.x always change the default machine type to the newest one

That's a bug actually. Now is too late to fix

Note You need to log in before you can comment on or make changes to this bug.