Bug 6831 - mirror is non-functional against WU-FTPD 2.6
mirror is non-functional against WU-FTPD 2.6
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: mirror (Show other bugs)
6.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Tim Powers
:
: 6830 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-08 14:38 EST by Daniel Senie
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 11:22:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 1999-11-08 14:38:26 EST
The mirror RPM needs to be updated using a patch available
on Sunsite (and an updated version is available there) that
fixes the issue which keeps it from working with an updated
server using WU-FTPD 2.6 or later.
Comment 1 Tim Powers 1999-11-08 14:42:59 EST
We will be releasing an errata update for this shortly.

Tim
Comment 2 Bill Nottingham 1999-11-08 15:04:59 EST
*** Bug 6830 has been marked as a duplicate of this bug. ***

Mirror isn't listed in Bugzilla as a component, thus my
posting it here.

The version of mirror shipped has a bug which prevents it
from working with the new WU-FTPD. A patch to the ftp.pl is
available from the mirror page on Sunsite. It also looks
like you're shipping an older version than what's available
on Sunsite, so updating the package to the latest version
may be the simplest thing to do (and make sure the patch is
included, of course)
Comment 3 Tim Powers 2000-02-03 11:10:59 EST
this was fixed by bero. In rawhide.
Comment 4 Daniel Senie 2000-02-03 18:07:59 EST
Releasing an RPM with the fix for 6.1 powertools would be a nice, friendly thing
to do for the user community. Considering this became an issue last October.
Comment 5 Tim Powers 2000-02-04 10:48:59 EST
Check in  ftp.redhat.com:/pub/rawhide/powertools . For whatever reason it wasn't
released to the public (why I have no idea, I have a feeling that it was
forgotten, and not intentional).

It should show up in the above location as soon as rawhide gets updated.

Tim
Comment 6 Daniel Senie 2000-02-04 11:05:59 EST
Right. But my comment is you've been selling a defective CD of "power tools" in
effect, and you should consider this as something to put an errata on, and put
it in the 6.1 power tools errata. What I'm concerned about is this next-release
mentality, where the next release may not be something users will jump to right
away. Fixing defective product in the present release is one of the things
that's made RedHat appear much more responsive to, say, Microsoft. Microsoft
tends to tell you to just buy the next release...

Granted folks can go find the fix in the Rawhide tree, but if you don't tell
them in the errata that a fix exists, they'll just not get it there. Since this
is an open source environment, the response is to just go get the sources and
build it without using the RPMs. The big value-add with RedHat is that patches
are easily applied with RPMs. If fixes are going to be delayed until subsequent
releases, it's not clear why anyone would use the power tools CDs to install
this type of software vs. just downloading tarballs and installing. Sorry for
the extended note here, but as someone who heavily uses and sells boxes
containing Linux, I'm a bit baffled by the procedures being followed for bug
fixes.
Comment 7 Tim Powers 2000-02-04 11:16:59 EST
I didn't mean to say that it wouldn't be released as an errata. That was not my
intention. My intention was to point you in the right direction now so that at
least you would have something to use until an errata update is issued. I am
sorting this out now with the current maintainer of the package to find out what
the issue was WRT releasing an errata back in October. An errata update will be
issued soon (after it has gone through QA etc. If you find any problems with
mirror in rawhide I would appreciate it if you could file another bug report
against that package).

Tim
Comment 8 Daniel Senie 2000-02-04 11:22:59 EST
Ah. OK. Sorry I misunderstood.

When I first uncovered the bug, I downloaded the patches to mirror and applied
them to a tarball and have been using that with no problems since that date.
I'll try to get a chance to download the RPM off of Rawhide and verify it if I
can get a few spare minutes.

Note You need to log in before you can comment on or make changes to this bug.