Bug 68310 - Ugly/fixed width fonts on various web sites
Ugly/fixed width fonts on various web sites
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
http://slashdot.org/
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-08 21:00 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 17:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-08 21:00:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Many fonts on various sites are not working; coming up as a courier/fixed width
sort of thing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. fire up mozilla
2. go to slashdot.org, or look at the bugzilla bug report forms.

Actual Results:  Font chosen for many parts of sites is courier.  (E.g. the font
that this typing is being rendered in on this bug form is somewhat illegible.)

Expected Results:  font selected should be in same family as that specified.

Additional info:

I did not deselect any fonts during install.
Mozilla is one of the first things a reviewer will see.
(I also noticed that the default Konsole font is bad, this might be related?)
Comment 1 Peter van Egdom 2002-07-09 17:31:36 EDT
You need to manually install the 75dpi and 100dpi fonts for
XFree86 (due to a bug, these got excluded by the installer).

You can find these fonts at CD 2 of Limbo.

(
 - Install CD 2 of Limbo in CD-ROM.
 - Become root ("su -")
 - "mount /mnt/cdrom"
 - "cd /mnt/cdrom/RedHat/RPMS"
 - "rpm -ivh XFree86-100dpi-fonts-4.2.0-52.i386.rpm"
 - "rpm -ivh XFree86-75dpi-fonts-4.2.0-52.i386.rpm"
)

Good luck ...
Comment 2 Christopher Blizzard 2002-07-09 23:42:01 EDT
Fixed in rawhide.
Comment 3 Need Real Name 2002-07-10 18:55:50 EDT
Well, I just installed the 75 and 100 dpi fonts as suggested, and while this
does appear to have fixed the issue in Konsole, it did NOT fix the issue with
fonts in Mozilla.  Slashdot still comes up with courier fonts.
Here are the XFree86.*font rpms installed:

[ph@localhost 100dpi]$ rpm -qa|grep XFree86-.*font
XFree86-75dpi-fonts-4.2.0-52
XFree86-font-utils-4.2.0-52
XFree86-truetype-fonts-4.2.0-52
XFree86-100dpi-fonts-4.2.0-52
XFree86-base-fonts-4.2.0-52
Comment 4 Need Real Name 2002-07-10 19:04:38 EDT
Doh!  Right after I send in the remark that Moz fonts weren't fixed, I realized
I needed to restarted xfs (and X, of course.)  So the installation of those two
font sets DOES appear to have fixed this issue.

Another bug bites the dust.  :-)

Note You need to log in before you can comment on or make changes to this bug.