Bug 683102 - FTBFS
FTBFS
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dev86 (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Novotny
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 10:10 EST by Zenon Panoussis
Modified: 2014-02-02 17:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 09:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2011-03-08 10:10:11 EST
Building dev86-0.16.17-15.1.el6.src.rpm from source gets stuck with an interactive dialogue:

make[3]: Entering directory `/root/rpmbuild/BUILD/dev86-0.16.17/libc'
sh Config_sh

 1) (ON)    Library of bcc helper functions
 2) (ON)    Minimal syscalls for BIOS level
 3) (ON)    Console io functions for BIOS and DOS.
 4) (ON)    Unix error functions
 5) (ON)    Managment for /etc/passwd /etc/group /etc/utmp
 6) (OFF)   Linux-i386 system call routines GCC
 7) (ON)    GNU termcap routines
 8) (ON)    Bcc 386 floating point
 9) (ON)    Linux-i386 system call routines
10) (ON)    Example kernel include files and syscall.dat
11) (ON)    Malloc routines
12) (ON)    Various unix lib functions
13) (ON)    Msdos system calls
14) (ON)    Regular expression lib
15) (ON)    Stdio package
16) (ON)    String and memory manipulation
17) (ON)    Linux-8086 system call routines
18) (ON)    Termios functions 
19) (ON)    Unix time manipulation functions.

Select config option to flip [or quit] >

Hitting <enter> allows the build to resume and finish correctly, but this interactivity violates RH policy and prevents automated rebuilds.
Comment 2 RHEL Product and Program Management 2011-03-08 10:39:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Zenon Panoussis 2011-03-08 10:43:27 EST
Passing a non-empty DIST to /root/rpmbuild/BUILD/dev86-0.16.17/libc/Config_sh would set RUNNING=0 in line 42 and solve the problem.

(In reply to comment #2)
Bumping up to v 6.1, otherwise it will make it to the next release too.
Comment 4 Michal Novotny 2013-06-18 09:39:16 EDT
(In reply to Zenon Panoussis from comment #3)
> Passing a non-empty DIST to
> /root/rpmbuild/BUILD/dev86-0.16.17/libc/Config_sh would set RUNNING=0 in
> line 42 and solve the problem.
> 
> (In reply to comment #2)
> Bumping up to v 6.1, otherwise it will make it to the next release too.

I've triaged it and it seems to be fine as it passes automatic build because of DIST is set in this time and it asks use only when DIST is not set, i.e. the rpmbuild is being run manually therefore I see no regression.

Zenon, if you need it for your automatic build just set the DIST variable and it's fine. Considering this do you really thing it's still an issue?

Thanks,
Michal
Comment 5 Michal Novotny 2013-06-25 09:28:38 EDT
No activity on bug for one week and analysis show this is not issue for automatic builds as the DIST is set in this case.

Closing as NOTABUG.

If somebody find any issue using with the current functionality, feel free to re-open.

Thanks,
Michal

Note You need to log in before you can comment on or make changes to this bug.