Bug 683108 - System settings not all set in GUI for fresh DB
System settings not all set in GUI for fresh DB
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity low (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-03-08 10:21 EST by Jay Shaughnessy
Modified: 2011-05-23 21:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-03-08 10:21:05 EST
1) -Ddbsetup

2) Start CoreGUI

3) Admin->System Settings

4) Inspect the Yes/No radio box props

5) Try to save a change to, say, Agent suspect down time

For me, this failed and I had to explicitly set all of the Yes/No props.  These should be set to defaults at install time and should not need to be set in the GUI when visiting system settings (of course, they should be able to be changed as desired).
Comment 1 John Mazzitelli 2011-03-08 10:28:32 EST
we need to look at the data in RHQ_SYSTEM_CONFIG and make sure the values coming out of it and into the radio button components are valid values. If the setValue() values of the radio buttons are what the component wants (non-null Boolean) then it won't render any value and you will be forced to enter one.
Comment 2 John Mazzitelli 2011-03-08 11:09:42 EST
the problem is enable_debug and enable_experimental settings aren't in rhq_system_config by default. I made the system config view more tolerant in any case where a config setting isn't in the db but we have a default value we can assume.

commit 424ea1880f8897351d70f6f138c27a4b89b89513
Comment 3 Ian Springer 2011-03-10 12:34:29 EST
With a fresh DB, in addition to the two mentioned above, the following properties were also flagged as invalid when I tried to save the system settings:

Enable Agent Auto-Updates
Reindex Data Tables Nightly

Strangely, they had values (i.e. one of the Yes/No radio buttons was selected), so I'm not sure why they were considered invalid.
Comment 4 John Mazzitelli 2011-03-10 12:38:22 EST
I'm gonna flip this back to ON_QA and see how testing goes. My fix was general - it should correct any missing props.
Comment 5 Mike Foley 2011-04-20 19:12:58 EDT
this is verified in the 4/29/2011 release testing.
Comment 6 Corey Welton 2011-05-23 21:15:41 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:15:41 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 8 Corey Welton 2011-05-23 21:15:43 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 9 Corey Welton 2011-05-23 21:15:46 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.