This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 683145 - [abrt] gnome-packagekit-2.91.90-1.fc15: g_settings_schema_new: Process /usr/bin/gpk-prefs was killed by signal 6 (SIGABRT)
[abrt] gnome-packagekit-2.91.90-1.fc15: g_settings_schema_new: Process /usr/b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
15
i686 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:d69b7d588a1f0f72cca99522cc4...
:
: 695725 (view as bug list)
Depends On:
Blocks: F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-03-08 11:47 EST by Christoph Wickert
Modified: 2011-04-26 11:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 06:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (8.71 KB, text/plain)
2011-03-08 11:47 EST, Christoph Wickert
no flags Details

  None (edit)
Description Christoph Wickert 2011-03-08 11:47:09 EST
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 8919 bytes
cmdline: gpk-prefs
component: gnome-packagekit
Attached file: coredump, 1318912 bytes
crash_function: g_settings_schema_new
executable: /usr/bin/gpk-prefs
kernel: 2.6.38-0.rc5.git1.1.fc15.i686
package: gnome-packagekit-2.91.90-1.fc15
rating: 4
reason: Process /usr/bin/gpk-prefs was killed by signal 6 (SIGABRT)
release: Fedora release 15 (Lovelock)
time: 1299599283
uid: 500

comment
-----
gpk-prefs crashes when gnome-settings-deamon is not installed:

$ gpk-prefs 

GLib-GIO-ERROR **: Settings schema 'org.gnome.settings-daemon.plugins.updates' is not installed

aborting...
Aborted (core dumped)

As the preferences are now a control-center plugin, I'm afraid that gnome-packagekit needs to require gnome-control-center and gnome-settings-deamon. I dislike these deps but I'm afraid at least the latter is recommended.

How to reproduce
-----
1. Boot F15 Alpha Xfce
2. yum update, yum -y remove gnome-settings-daemon
3. launch gpk-prefs
Comment 1 Christoph Wickert 2011-03-08 11:47:16 EST
Created attachment 482951 [details]
File: backtrace
Comment 2 Christoph Wickert 2011-03-08 12:04:14 EST
I am marking this F15Blocker-xfce because having gnome-packagekit but not gnome-settings-daemon is the default in the Xfce spin.
Comment 3 Aaron Sowry 2011-03-10 06:37:50 EST
Package: gnome-packagekit-2.91.90-1.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Rawhide)


How to reproduce
-----
1. Start gpk-prefs
2.
3.


Comment
-----
The following is output when run from the command line:

[aaron@jules ~]$ gpk-prefs
Gtk-Message: Failed to load module "pk-gtk-module"

** (gpk-prefs:5243): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.


GLib-GIO-ERROR **: Settings schema 'org.gnome.settings-daemon.plugins.updates' is not installed

aborting...
Aborted (core dumped)
Comment 4 Aaron Sowry 2011-03-10 06:46:30 EST
For the record, I have the following packages already installed:

gnome-settings-daemon-2.91.9-6.fc16.x86_64
control-center-2.91.6-10.fc16.x86_64
Comment 5 Javier Jardón 2011-03-13 23:49:18 EDT
Package: gnome-packagekit-2.91.90-1.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Rawhide)


How to reproduce
-----
1. Simply trying to open the program
Comment 6 Christoph Wickert 2011-04-11 07:24:12 EDT
Richard, are there any plans to fix the missing dependency on control-center for F15?
Comment 7 Adam Williamson 2011-04-15 13:56:38 EDT
Discussed at 2011-04-15 blocker review meeting. Accepted as NTH: this hits criterion "# All applications listed under the Applications menu or category must start successfully " for the non-blocking desktop Xfce, hence it is NTH by policy.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Richard Hughes 2011-04-26 06:39:22 EDT
* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> - 3.0.0-2
- Add requires of gnome-settings-daemon to fix #683145
Comment 9 Richard Hughes 2011-04-26 06:55:38 EDT
*** Bug 695725 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2011-04-26 06:59:28 EDT
Will this fix be in F15?
Comment 11 Adam Williamson 2011-04-26 11:07:45 EDT
I haven't seen 3.0.0-2 submitted as an update yet.

Richard, it's usually best to use the update process to handle bug closing for you, so it gets closed when the update is actually approved...

Note You need to log in before you can comment on or make changes to this bug.