Bug 68315 - Applications menu categories untranslated
Applications menu categories untranslated
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-panel (Show other bugs)
limbo
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-08 22:19 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 12:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot (59.74 KB, image/png)
2002-07-08 22:19 EDT, Christian Rose
no flags Details
Patch for POTFILES.in (1.45 KB, patch)
2002-07-10 21:20 EDT, Christian Rose
no flags Details | Diff

  None (edit)
Description Christian Rose 2002-07-08 22:19:05 EDT
Tested with Limbo and sv_SE.UTF-8 as locale.

The entries in the gnome "Applications" menu are not translated into Swedish,
although their contents should be translated in gnome 2.0.
Comment 1 Christian Rose 2002-07-08 22:19:58 EDT
Created attachment 64346 [details]
Screenshot
Comment 2 Richard Hult 2002-07-09 05:42:25 EDT
Those entries are translated in upstream GNOME, it looks like the translation is
just not included in the packages.
Comment 3 Havoc Pennington 2002-07-10 18:18:06 EDT
You need to translate them in the "redhat-menus" module on Elvis.
Comment 4 Christian Rose 2002-07-10 19:28:43 EDT
Oh. But only the message "Applications" is marked for translation in the
redhat-menus module. It seems the other desktop and directory files are not
hooked up in POTFILES.in (at least that's what "intltool-update -M" shows).

Also, the redhat.menus module is not in "translate" on i18n.redhat.com, nor is
it on the http://i18n.redhat.com/i18n/ stats page. Teg?
Comment 5 Havoc Pennington 2002-07-10 20:39:01 EDT
If you know how to fix potfiles.in I'd appreciate it.

It isn't on the i18n page probably because I was sort of waiting until the menus
were a bit more final. I expect to change those strings a lot still (not the
directory names probably, but adding/removing other stuff).
Comment 6 Christian Rose 2002-07-10 21:19:17 EDT
I'm attaching a patch for the POTFILES.in file.

Personally I'd prefer if it was added sooner than later to the status pages even
though it's not finished yet. Then it'll give translators a head start.
Comment 7 Christian Rose 2002-07-10 21:20:17 EDT
Created attachment 64704 [details]
Patch for POTFILES.in
Comment 8 Havoc Pennington 2002-07-10 22:26:53 EDT
teg is there a way to give translators access to modify POTFILES.in?

Christian is there an automatic way to generate it?
Comment 9 Christian Rose 2002-07-11 06:20:34 EDT
I don't think so. "intltool-update -M" will find all missing files but it
doesn't know if the files are included in the tarball, so manual inspection of
Makefiles is necessary.
Comment 10 Trond Eivind Glomsrxd 2002-07-11 11:00:24 EDT
I've added it to the translate module... there is no pot file there, though.
Comment 11 Christian Rose 2002-07-11 12:17:03 EDT
"intltool-update --pot" will generate a pot file.
Comment 12 Havoc Pennington 2002-07-29 12:24:01 EDT
Marking the head of the priority queue with priority high
Comment 13 Havoc Pennington 2002-08-02 15:00:11 EDT
as far as I know things are good (redhat-menus on status page, everything in
POTFILES.in)

Note You need to log in before you can comment on or make changes to this bug.