Bug 68323 - Kernel: missing package dependency for tk causes "make xconfig" to fail
Summary: Kernel: missing package dependency for tk causes "make xconfig" to fail
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-09 04:18 UTC by Mark McClelland
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 04:45:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McClelland 2002-07-09 04:18:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
When "make xconfig" is run from within the kernel source directory, it will exit
with an error due to the "wish" command not being available. This command is
part of the tk package, but "rpm -q --requires kernel-source" does not list tk
as a requirement. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
On a system that does not have the tk package installed:
1. su -
2. cd /usr/src/linux-2.4.18-5.58
3. make xconfig
	

Actual Results:
 Relevant make output:
  wish -f scripts/kconfig.tk
  make: wish: Command not found
  make: *** [xconfig] Error 127

Expected Results:  The xconfig GUI should have appeared

Additional info:

NOTE: make xconfig works after the tk package from Disc 3 is installed.


Note You need to log in before you can comment on or make changes to this bug.