Bug 683239 - Missing require for python-ssl in bcfg2-server
Summary: Missing require for python-ssl in bcfg2-server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bcfg2
Version: el5
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-08 21:42 UTC by Matt Whiteley
Modified: 2011-10-09 21:02 UTC (History)
2 users (show)

Fixed In Version: bcfg2-1.1.3-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-02 13:06:45 UTC
Type: ---


Attachments (Terms of Use)

Description Matt Whiteley 2011-03-08 21:42:23 UTC
Description of problem:
After a yum install of bcfg2-server, when attempting `bcfg2-admin init` a failure occurs if python-ssl wasn't already installed.

Version-Release number of selected component (if applicable):
1.1.0-2.el5

How reproducible:
Always

Steps to Reproduce:
1. Yum install bcfg2-server on a system that doesn't have python-ssl
2. Initialize the bcfg2 repo
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/bcfg2-admin", line 7, in ?
    import Bcfg2.Server.Core
  File "/usr/lib/python2.4/site-packages/Bcfg2/Server/Core.py", line 12, in ?
    from Bcfg2.Component import Component, exposed
  File "/usr/lib/python2.4/site-packages/Bcfg2/Component.py", line 19, in ?
    from Bcfg2.SSLServer import XMLRPCServer
  File "/usr/lib/python2.4/site-packages/Bcfg2/SSLServer.py", line 19, in ?
    import ssl
ImportError: No module named ssl

Expected results:
Repository created successfuly in /var/lib/bcfg2

Additional info:

Comment 1 Fedora Update System 2011-06-02 12:59:34 UTC
bcfg2-1.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bcfg2-1.1.2-1.el5

Comment 2 Fabian Affolter 2011-06-02 13:06:45 UTC
I will close this bug because we decided not to push new Bcfg2 packages to stable because of possible breakages.  Please use the URL in Comment #1 to download the latest package for EPEL 5.

Comment 3 Fedora Update System 2011-09-07 22:16:46 UTC
bcfg2-1.1.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bcfg2-1.1.2-2.fc15

Comment 4 Fedora Update System 2011-09-07 22:16:59 UTC
bcfg2-1.1.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bcfg2-1.1.2-2.fc14

Comment 5 Fedora Update System 2011-09-07 22:17:12 UTC
bcfg2-1.1.2-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bcfg2-1.1.2-2.el5

Comment 6 Fedora Update System 2011-09-07 22:17:24 UTC
bcfg2-1.1.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/bcfg2-1.1.2-2.el6

Comment 7 Fedora Update System 2011-09-18 00:58:31 UTC
bcfg2-1.1.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-09-18 00:58:49 UTC
bcfg2-1.1.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-09-22 22:13:34 UTC
bcfg2-1.1.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/bcfg2-1.1.3-1.el6

Comment 10 Fedora Update System 2011-09-22 22:13:51 UTC
bcfg2-1.1.3-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bcfg2-1.1.3-1.el5

Comment 11 Fedora Update System 2011-10-09 21:00:50 UTC
bcfg2-1.1.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-10-09 21:02:34 UTC
bcfg2-1.1.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.