Bug 683254 - Kernel messages can be still seen after init process has been started
Kernel messages can be still seen after init process has been started
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 17:23 EST by Artem S. Tashkinov
Modified: 2011-03-10 03:51 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-10 03:51:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem S. Tashkinov 2011-03-08 17:23:43 EST
Description of problem: I still see kernel messages after /sbin/init process has been started


Version-Release number of selected component (if applicable): Fedora 15 alpha


How reproducible: always


Steps to Reproduce:
1. Install minimum Fedora 15 installation
2. Boot without rhgb and quiet options
3. 
  
Actual results: kernel messages can be seen after "Welcome to Fedora release 15" message


Expected results: no kernel messages dumped after this message


Additional info:
Comment 1 Bill Nottingham 2011-03-09 10:59:22 EST
This is expected; if you don't boot with 'quiet', the kernel's not quiet.
Comment 2 Artem S. Tashkinov 2011-03-09 12:51:42 EST
This is *not* expected, because all previous RH and Fedora releases don't have this "feature".

I'm now running Fedora 14 without quiet boot option and there are no kernel messages in any of text terminals.
Comment 3 Bill Nottingham 2011-03-09 13:53:53 EST
There used to be code that frobbed the kernel loglevel on boot in rc.sysinit. This was removed in Fedora 14 for a variety of reasons:

1) This didn't do anything useful prior to rsyslog, as sysklogd would reset it.
2) This overrides the kernel commandline, for people who want to temporarily reset it there
3) This actually turns messages back on out from underneath plymouth, which isn't nice.

From a release note that should have gone into Fedora 14 (but did not):

...
Use of the 'LOGLEVEL' parameter in /etc/sysconfig/init to set the console loglevel is no longer supported. To set the console loglevel, pass 'loglevel=<number>' as a boot time parameter.

...
Comment 4 Lennart Poettering 2011-03-09 18:04:59 EST
systemd doesn't actually fiddle with this. I think Plymouth does that now.
Comment 5 Artem S. Tashkinov 2011-03-10 03:51:19 EST
(In reply to comment #3)

You reasoning looks sound even though I'm not entirely content with it.

1) Kernel boot messages often are the only resort of seeing and understanding why the system doesn't boot properly or misbehaves. At the same time removing quiet boot option makes the system overly verbose.
2) A lot of people may disagree why you are changing 13+ years defaults.

Feel free to close this bug report and I'd like to know (link will suffice) if this change/proposal has been discussed on a mailing list.

Note You need to log in before you can comment on or make changes to this bug.