Bug 68329 - No /proc/profile support without CONFIG_SMP
Summary: No /proc/profile support without CONFIG_SMP
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-09 06:34 UTC by davidsf
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:56:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description davidsf 2002-07-09 06:34:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020608

Description of problem:
It is impossible to build a kernel with data in /proc/profile without building
SMP. The culprit seems to be the patch linux-2.4.9-nmiprofiling.patch, which
removes the code without even adding a CONFIG_NMI or like.

Surely some explanation is due at the least.

Version-Release number of selected component (if applicable):
2.4.18-3

How reproducible:
Always

Steps to Reproduce:
1. Add profile=# to your non-SMP kernel command line
2. Boot
3. cat /proc/profile
4. Spend about an hour messing with readprofile before pulling the source, then
looking at the obscure undocumented patches in the 2.4.18-3 kernel rpm.
	

Actual Results:  There is nothing in /proc/profile!

Expected Results:  There should be useful data there.

Additional info:

It's always disappointing to find features deleted in redhat packages, with no
explanation.

Comment 1 davidsf 2002-07-13 21:44:55 UTC
Correction: it is CONFIG_X86_LOCAL_APIC, which is on by default in defconfig and
in the package.

It is still unfortunate that without this option there is no /proc/profile, but
it  is a more acceptable workaround than setting CONFIG_SMP.

Comment 2 davidsf 2002-07-15 01:51:57 UTC
Actually the nmiprofiling patch cuts profiling out of every code path but the
NMI event itself, so even enabling the local APIC is not a workaround.

Comment 3 Arjan van de Ven 2003-06-07 18:56:31 UTC
fixed in current erratum 


Note You need to log in before you can comment on or make changes to this bug.