Bug 683290 - [abrt] ibus-1.3.9-2.fc14: connection.py:631:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Unknown method IsEnabled on /org/freedesktop/IBus/InputContext_794
[abrt] ibus-1.3.9-2.fc14: connection.py:631:call_blocking:DBusException: org....
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:51e47ac2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 20:13 EST by Scott Tsai
Modified: 2011-03-18 00:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 00:05:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2011-03-08 20:13 EST, Scott Tsai
no flags Details

  None (edit)
Description Scott Tsai 2011-03-08 20:13:47 EST
abrt version: 1.1.17
architecture: x86_64
cmdline: /usr/bin/python /usr/share/ibus/ui/gtk/main.py
component: ibus
executable: /usr/share/ibus/ui/gtk/main.py
kernel: 2.6.35.11-83.fc14.x86_64
package: ibus-1.3.9-2.fc14
reason: connection.py:631:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Unknown method IsEnabled on /org/freedesktop/IBus/InputContext_794
release: Fedora release 14 (Laughlin)
time: 1299632068
uid: 500

backtrace
-----
connection.py:631:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: Unknown method IsEnabled on /org/freedesktop/IBus/InputContext_794

Traceback (most recent call last):
  File "/usr/share/ibus/ui/gtk/panel.py", line 491, in __status_icon_activate_cb
    menu = self.__create_im_menu()
  File "/usr/share/ibus/ui/gtk/panel.py", line 449, in __create_im_menu
    if self.__focus_ic == None or not self.__focus_ic.is_enabled():
  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 214, in is_enabled
    return self.__context.IsEnabled()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 631, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.UnknownMethod: Unknown method IsEnabled on /org/freedesktop/IBus/InputContext_794

Local variables in innermost frame:
byte_arrays: False
self: <dbus.connection.Connection object at 0x7f4a7becd5f0>
args: ()
utf8_strings: False
bus_name: 'org.freedesktop.IBus'
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_794')
timeout: -1.0
signature: None
dbus_interface: 'org.freedesktop.IBus.InputContext'
message: <dbus.lowlevel.MethodCallMessage object at 0x7f4a7c11b918>
method: 'IsEnabled'

How to reproduce
-----
1. Open Google Chrome 10.0.648.127 beta
2. Browse to http://docs.google.com
3. "Create new" -> "Document"
4. Activate iBus and start typing. In my case I'm using ibus-chewing for traditional Chinese.
Comment 1 Scott Tsai 2011-03-08 20:13:50 EST
Created attachment 483083 [details]
File: backtrace
Comment 2 fujiwara 2011-03-10 21:31:01 EST
I could not reproduce your problem.
I tried ibus-chewing on google document with anonymous account with chrome browser.
I used google-chrome-stable-9.0.597.98-74359.x86_64
% rpm -q ibus-chewing
ibus-chewing-1.3.9.2-1.fc14.x86_64

Do you always encounter your problem?
Could you also explain which key sequences are typed with ibus-chewing?

We can avoid any errors with try-except but it also would hide other problems.
So if we fix your problem, we'd like to fix the root cause and need to reproduce your problem.
Comment 3 Scott Tsai 2011-03-11 03:04:11 EST
Fujiwara san, I just tried and can't reproduce the bug in 5 minutes either.

I'm assuming that the DBus service at /org/freedesktop/IBus/InputContext_794 usually have the method IsEnabled(), right?
If the process backing /org/freedesktop/IBus/InputContext_794 crashed, could it 
cause this error?

In my experience, Google Chrome on Linux has problems when using the Word processor at http://docs.google.com with an iBus input method active.
Comment 4 fujiwara 2011-03-11 06:11:15 EST
(In reply to comment #3)
> Fujiwara san, I just tried and can't reproduce the bug in 5 minutes either.
> 
> I'm assuming that the DBus service at /org/freedesktop/IBus/InputContext_794
> usually have the method IsEnabled(), right?

Yes, it's a dbus function.
ibus-daemon provides IsEnabled().
It seems your ibus panel failed to connect ibus-daemon via dbus.
% ps -ef | grep ibus/ui
5071 /usr/bin/python /usr/share/ibus/ui/gtk/main.py


> If the process backing /org/freedesktop/IBus/InputContext_794 crashed, could it 
> cause this error?

From your stack, if IsEnabled() is failed, the ibus panel icon cannot show the IM engine list.
But I guess, if the problem can be caused, it's not IsEnabled() only but also other dbus methods are not connected.
Currently we'd think this problem could not be happened logically.

E.g. your CPU or memory might be exhausted, I'm not sure.

> In my experience, Google Chrome on Linux has problems when using the Word
> processor at http://docs.google.com with an iBus input method active.

I can use the word processor without seeing any errors.
If you won't encounter the problem, maybe I'd like to close the bug.
Comment 5 fujiwara 2011-03-18 00:05:46 EDT
The latest is ibus-1.3.9-3.fc14 .
If you will see the same error again, please comment it here again.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.