Bug 6833 - expiring doesn''t always work with autofs
expiring doesn''t always work with autofs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-08 15:15 EST by templon
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-31 14:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description templon 1999-11-08 15:15:21 EST
I have autofs set up to work the same on three machines,
i.e. i use the same autofs config files on all three.
This means sometimes autofs is mapping via a link to
a local directory, or sometimes actually mapping over
the net.

The problem has to do with when it maps via a link to
a directory local to the machine.  Sometimes (and I don't
have any idea why it doesn't happen all the time),
expiring doesn't appear to be successful.  I get messages
like this in my /var/log/messages:

Nov  7 15:20:19 visar automount[17608]: expired /data/argon
Nov  7 15:35:19 visar automount[17648]: expired /data/argon
Nov  7 15:50:19 visar automount[17686]: expired /data/argon
Nov  7 16:05:19 visar automount[17724]: expired /data/argon

ad infinitum.  the only fix seems to be to reboot the
machine.  I also notice messages when rebooting,
AF_INET forgot to set XXXX when YYY.  Fix it!
etc.

I am sure this is not the correct text, but it does not
show up in log files, only on the console so it is
a pain to capture the text of those messages.  I am
not sure that they have anything to do with autofs
problem, but they appear to have to do with rpc
which does have to do with autofs if I am correct.
Comment 1 Nalin Dahyabhai 2000-02-02 10:14:59 EST
Does this still happen with autofs-3.1.3-9 from Red Hat Linux 6.1 or
autofs-3.1.4-2 from Raw Hide?  Looking through the autofs code, you'd
only see this happen if the removal of the link failed, because autofs
appears to ignore the code returned when it attempts to remove the link.
Comment 2 templon 2000-02-02 13:31:59 EST
The damndest thing ... I just checked my logs, and for some reason
it is not happening anymore.  Even stranger, ALL messages about expiring
directories have vanished.  Normally whenever I would log off and go
home, about 15 min later there would be some message about expiration.
Now there is nothing.

On other machines, the log messages are still present (although I did
not see any of the massive repetition which I posted the original
bug report about.)  The only things which are obviously
changed is that on the machine which no longer has the problem
(nor the normal expiry messages), I have modified inetd.conf
so that linuxconf is commented out, and also on this machine
I installed the "junkbuster" cookie-filtering program.
Comment 3 Nalin Dahyabhai 2000-02-02 14:48:59 EST
That is indeed odd.  If the machines in question are all running the same
versions of autofs and the kernel, they should all be behaving similarly
wrt expirations.  I can find no differences in this area between autofs 3.1.2
and 3.1.4, nor in the autofs filesystem driver in 2.2.12 and 2.2.14.
Comment 4 templon 2000-02-02 14:55:59 EST
One more thing -- I went back thru my logs to find out when the
autofs messages stopped.  They stopped right after a reboot.
I looked to see what had been changed in the month prior to
reboot (this is RH 6.0) --- I must have installed a sysklogd
patch since the rc.d file for syslog was changed.  Perhaps this is
why the logging changed?  i cannot find much else.

I have recently ordered RH 6.1 and will see what happens when
I install it.  Right now I have no clues (and also it is a non
problem).
Comment 5 Nalin Dahyabhai 2000-02-07 08:20:59 EST
I doubt the syslog init script would have any effect -- it only starts and stops
the service, and the configuration file (/etc/syslog.conf) is where the actual
modifications would need to be made.  I still get the occasional expire message
in my log files here, but nothing repetitive.  The NEWS file in /usr/doc/autofs*
doesn't shed any light on this, either.
Comment 6 Nalin Dahyabhai 2000-05-31 14:43:01 EDT
It''s been a while since the last entry on this bug.  If there''s nothing else,
I''ll go ahead and mark it as resolved.

Note You need to log in before you can comment on or make changes to this bug.