Bug 683383 - missing section images-xen for x86_64
missing section images-xen for x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-09 05:15 EST by Andrew Jones
Modified: 2013-07-04 08:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: lorax-0.3.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 00:59:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of virt-install (11.11 KB, text/plain)
2011-03-14 04:30 EDT, Alejandro Liu
no flags Details

  None (edit)
Description Andrew Jones 2011-03-09 05:15:34 EST
# virt-install -p -n f15-64pv -l $REPOS/fedora/linux/development/15/x86_64/os -f /vm/images/f15-64pv -s 7 --vcpus=2 -r 1024 -x console=hvc0


Starting install...
Retrieving file .treeinfo...                             |  796 B     00:00     
ERROR    No section: 'images-xen'
Comment 1 Alejandro Liu 2011-03-14 04:26:59 EDT
This used to work quite well in Fedora 14 (and F13).

When I manually add to .treeinfo (just like in Fedora 14):

----
[images-xen]
kernel = images/pxeboot/vmlinuz
initrd = images/pxeboot/initrd.img
----

The CentOS 5.5 virt-installer is able to find the kernel and initrd files.  However the kernel panics soon after (unable to find root) looks like it is not recognising the initrd image.
Comment 2 Alejandro Liu 2011-03-14 04:30:33 EDT
Created attachment 484098 [details]
Output of virt-install

virt-install --name=f15 --disk pool=default,size=15 --ram=512 --vcpus=1 --location=nfs:172.20.128.101:/data/d01/tlbox/swrepo/f15dev-os-x86_64 --nographics --paravirt --network=network:vlan0

The nfs location is a mirror of the "development/15/x86_64/os" repository.
Comment 3 Alejandro Liu 2011-03-14 04:40:52 EDT
I believe this should be a "blocker" bug as it impact the following release criteria:

15. The release must boot successfully as a virtual guest in a situation where the virtual host is running a supported Xen implementation
Comment 4 James Laska 2011-03-15 08:07:24 EDT
(In reply to comment #3)
> I believe this should be a "blocker" bug as it impact the following release
> criteria:
> 
> 15. The release must boot successfully as a virtual guest in a situation where
> the virtual host is running a supported Xen implementation

Agreed.  

mgracik: if you agree, I'll go ahead and mark this as an accepted beta blocker.

https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 5 Martin Gracik 2011-03-15 08:17:56 EDT
I agree, I already have a patch for this in rawhide.
Comment 6 Fedora Update System 2011-03-15 10:19:54 EDT
lorax-0.3.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lorax-0.3.1-1.fc15
Comment 7 Alejandro Liu 2011-03-15 12:21:40 EDT
Hi,

Took another look at the output logs and the telling item is:

[    0.000000] initrd too large to handle, disabling initrd

Since F15 does not use the stage2.img, the initrd.img becomes too big for Xen (at least the CentOS 5.5 build) which uses xen 3.0.3.
Comment 8 James Laska 2011-03-15 12:38:21 EDT
(In reply to comment #7)
> Hi,
> 
> Took another look at the output logs and the telling item is:
> 
> [    0.000000] initrd too large to handle, disabling initrd
> 
> Since F15 does not use the stage2.img, the initrd.img becomes too big for Xen
> (at least the CentOS 5.5 build) which uses xen 3.0.3.

That is a new and different issue from what is being tracked in this bug report.  Can you please open a new bug report against the kernel for this?  You may also want to raise this topic for discussion on virt@lists.fedoraproject.org.
Comment 9 Alejandro Liu 2011-03-15 13:38:15 EDT
Sorry, actually my issue is related to

https://bugzilla.redhat.com/show_bug.cgi?id=682555

And the increased memory requirements by Anaconda (I was using a 512M VM).
Comment 10 Fedora Update System 2011-03-21 10:01:51 EDT
lorax-0.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lorax-0.3.2-1.fc15
Comment 11 James Laska 2011-03-21 13:43:10 EDT
Verified this fix in a private boot.iso build using the updated lorax.  The generated .treeinfo contains [images-xen]

http://fpaste.org/CJFw/
Comment 12 Fedora Update System 2011-03-23 00:58:47 EDT
lorax-0.3.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.