Bug 683428 - Inappropriate ioctl for device When set harddisk to low performance status on RHEL 6.1 host
Inappropriate ioctl for device When set harddisk to low performance status on...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: John Snow
aihua liang
:
Depends On: 662903
Blocks: 580954
  Show dependency treegraph
 
Reported: 2011-03-09 07:02 EST by Joy Pu
Modified: 2017-11-16 17:45 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 662903
Environment:
Last Closed: 2017-11-16 17:45:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Joy Pu 2011-03-09 07:07:39 EST
Find this problem again in RHEL 6.1 host and RHEL 6.1 guest. And conform with Christoph, and open this bug as his advice.
Comment 10 Xueqiang Wei 2015-04-28 04:43:15 EDT
Hi Kevin,

I reproduce this bug on RHEL6.7 host and RHEL6.7 guest

Host:
kernel-2.6.32-551.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.465.el6.x86_64


If it will be fixed in rhel6?


Thanks
Xueqiang
Comment 11 Kevin Wolf 2015-04-28 09:27:41 EDT
Certainly not in RHEL 6. I'm not sure if it's worth fixing at all because it
doesn't actually provide any additional functionality or fix a real bug. It would
only make the warning go away with no other change in behaviour.

However, as this is IDE, I'm reassigning this to John and let him decide.
Comment 12 John Snow 2015-06-23 19:00:45 EDT
Not likely to be fixed in the immediate future; the SET_FEATURES command is complicated (and mandatory) and even stubbing the responses to the satisfaction of HDParm will probably take a solid week to get right.

I don't think I'll close this bug, but I am going to kick the can down the road for now.

I will investigate fixing this upstream, but it won't hit 7.2.
Comment 15 aihua liang 2017-11-08 02:39:54 EST
Bug still exit in RHEL7.5
 
 kernel version: 3.10.0-772.el7.x86_64
 qemu-kvm-rhev version:qemu-kvm-rhev-2.10.0-4.el7.x86_64
Comment 16 John Snow 2017-11-16 17:45:48 EST
Closing this for our downstream version of this package as only a cosmetic problem.

If it is found to actually impair any technical operation, please re-open. Different performance modes in QEMU can be achieved by using throttling and performance settings on the host. We generally don't or will not be respecting requests from the guests to inhibit performance artificially through the IDE layer specifically.

For now, this is WONTFIX. If someone stumbles across this BZ from google and you are finding this bug is preventing you from performing some legitimate action with e.g. HDParm, please file a bug /upstream/ using the launchpad tracker, or reach out to us on the list at qemu-block@nongnu.org.

Thanks,
John

Note You need to log in before you can comment on or make changes to this bug.