Bug 68352 - Password mismatch on user_details.pxt
Summary: Password mismatch on user_details.pxt
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL: https://rhn.redhat.com/network/user/u...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-09 15:09 UTC by Matt Jamison
Modified: 2007-07-31 19:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 19:56:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josef Komenda 2002-07-09 15:09:24 UTC
Description of Problem: A problem seen intermittently in Galeon 1.2.0 and
reliably in Mozilla 1.0 (Win98). The passwords populated into the 'user details'
and 'my details' pages does not always match, so that any edits to those pages
will result in a rejection based on a password mismatch.


How Reproducible: On webqa:
Account - jkomenda
Pass - pink4all

Comment 1 Bret McMillan 2002-07-12 19:52:08 UTC
Am not seeing this on my galeon 1.2.1

I registered a new user to webqa db, then tried the webcode on my box, and
rhn.webqa.redhat.com.

So, need more info.

Comment 2 Josef Komenda 2002-07-16 20:55:26 UTC
This problem is also hapening in Satellite, and it prevents you from changing
premissions for users. To duplicate, install a satellite 1.1, create a new user,
and change the users' permissions. The password(s) will change when you save,
and you will not be able to log in as that user.

Comment 3 Josef Komenda 2002-07-16 21:14:22 UTC
Scratch that last entry - although this does affect the satellite, it does not
behave in the way described above.

Comment 4 Josef Komenda 2002-07-17 22:24:13 UTC
Chip, could you please look into this? This can be replicated on
sat-app.test.redhat.com by looking at:
http://sat-app.test.redhat.com/network/my_account/my_details.pxt

Username: sat-app
Password: pink4all

The problem also shows up for the initial user under:
http://sat-app.test.redhat.com/network/user/user_details.pxt?uid=1

Bret looked at that code and removed the password attrib in the form so we could
see what was being passed, and the error went away - he can tell you what he
modified in those files.

Comment 5 Josef Komenda 2002-07-17 23:29:00 UTC
Also, (and this is a little thing) the text for: 'User Roles' right above the
passwords, you can see that 'Channel Administrator' is displayed twice. Kindly
remove the duplication, both on the 'Your Account' and 'User Details' pages :-)

Comment 6 Josef Komenda 2002-07-18 21:54:44 UTC
Hmm.. not happening anymore. Bah!

Comment 7 Josef Komenda 2002-09-05 15:07:28 UTC
This has been figured out thanks to cturner. The problem is when you use Mozilla
or Galeon, and use the Manage Passwords feature. The variable name on the User
Details and My Details pages is the same as the login page, so Mozilla and
Galeon drop the value in. Changing the variable name on those two pages should
fix the problem.

Comment 8 Bret McMillan 2002-12-13 16:36:23 UTC
Should be fixed in titan-lite tree, joek, can you confirm?

Comment 9 Josef Komenda 2003-04-09 19:56:51 UTC
Fixed on the live site, will be in the next sat - closing.


Note You need to log in before you can comment on or make changes to this bug.