Bug 683589 - cups server error client-error-forbidden during failed add of network printer
cups server error client-error-forbidden during failed add of network printer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
14
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 14:18 EST by collura
Modified: 2011-04-23 00:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: 4.6.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-22 08:54:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collura 2011-03-09 14:18:40 EST
Description of problem:
  get error message and network printer doesnt get added

Version-Release number of selected component (if applicable):

  kdebase-6:4.5.5-1.fc14
  kernel-2.6.35.11-83.fc14 x86_64
  cups-1:1.4.6-1.fc14 x86_64 on f14kde
  gutenprint-cups-5.2.6-2.fc14 x86_64 f14kde


How reproducible:
  always

Steps to Reproduce:
1. system settings - printer configuration
2. click on 'new printer' and then click on 'new-network-printer' 
3. error window pops up with window title of 'CUPS server error - System Settings' and with text of 
"There was an error during the CUPS operation: 'client-error-forbidden'."
4. click <ok> in the error window to continue and after a bit a new printer dialog pops up for you to select a connection for with only 'other' in connection list and uri field blank.
5. if put 'lpd://ip-address-of-printer/queue' into uri then <forward> button is enabled and you can select the printer manufacturer from a list and then <forward> and then select model from a list and then <forward> and then name/describe/location it.
6.  but then when select <ok> you get the 'client-error-forbidden' error window again.  
7. if close the error window the new printer dialog just sits and waits until click <cancel>.

  
Actual results:
  error but printer not added

Expected results:
  no error and printer gets added

Additional info:

/var/log/cups/error_log :
'E [09/Mar/2011:12:46:29 -0500] Returning HTTP Forbidden for CUPS-Add-Modify-Printer (ipp://localhost/printers/<removed>) from localhost'

/var/log/cups/access_log:
localhost - - [09/Mar/2011:13:56:39 -0500] "GET /admin/conf/cupsd.conf HTTP/1.1" 401 0 - -
localhost - <removed username> [09/Mar/2011:13:56:39 -0500] "GET /admin/conf/cupsd.conf HTTP/1.1" 403 0 - -
localhost - - [09/Mar/2011:13:58:18 -0500] "POST / HTTP/1.1" 401 75 CUPS-Get-Devices successful-ok
localhost - - [09/Mar/2011:13:59:59 -0500] "POST / HTTP/1.1" 200 3152989 CUPS-Get-PPDs -
localhost - - [09/Mar/2011:14:03:03 -0500] "POST / HTTP/1.1" 200 3152989 CUPS-Get-PPDs -
localhost - <removed username> [09/Mar/2011:14:05:47 -0500] "POST / HTTP/1.1" 200 10026 CUPS-Get-PPD -
localhost - <removed username> [09/Mar/2011:14:06:01 -0500] "POST /admin/ HTTP/1.1" 403 10071 CUPS-Add-Modify-Printer successful-ok
Comment 1 Tim Waugh 2011-03-10 05:12:53 EST
Is that system-config-printer?  Could you please run this command from a terminal window, perform the same steps as above, and attach the log.txt please?

system-config-printer --debug > log.txt
Comment 2 collura 2011-03-10 17:20:45 EST
the previous output was generated by whatever the kde 'printer configuration' gui icon in the kde menu uses (i am currently more interested in vetting kde than in printing lol).


i tried command: 

  system-config-printer-kde --debug > log.txt

which fails with 'command not found' so produces no log.

however, when i grep for system-config-printer-kde i get a /usr/share/kde4/apps/system-config-printer-kde with files but not any in /usr/bin directory.
so is a /usr/bin/system-config-printer-kde launcher script just missing from /usr/bin that should be starting the /usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py script?

doh

fyi also had these installed on the fc14kde system: 

  kdeutils-printer-applet-6:4.5.5-1.fc14 (x86_64) 
  system-config-printer-kde-7:4.5.5-1.fc14 (x86_64)
  system-config-printer-libs-1.2.7-2.fc14 (x86_64)
  system-config-printer-udev-1.2.7-2.fc14 (x86_64)
  (system-config-printer is not listed as installed.)
Comment 3 Tim Waugh 2011-03-11 04:22:48 EST
OK, fixing component.
Comment 4 gene smith 2011-04-22 00:11:51 EDT
Was hoping this would be fixed in the latest kde upgrade to 4.6.2 today but no change. I assume this lack of prompt for root pwd is a bug in the kde wrapper around system-config-printer since this non-kde app works as expected (although with way too many password prompts as pointed out in another bug report).

FYI, there is some discussion and a proposed way to fix this on the fedore-kde list as seen here:

http://comments.gmane.org/gmane.linux.redhat.fedora.kde/8908

However, 4.6.2 seems to have the recommended strings but still fails to prompt for root password at all and so fails immediately.
Comment 5 Rex Dieter 2011-04-22 08:54:07 EDT
it works for me, using
system-config-printer-kde-4.6.2-2.fc14.x86_64

via systemsettings->printer configuration

note the priv elevation hack here won't work if envoking manually with
kcmshell4 system-config-printer-kde
you'll have to use something like
kdesu kcmshell4 system-config-printer-kde
for that.
Comment 6 gene smith 2011-04-23 00:10:35 EDT
Now also get a pwd prompt immediately on doing systemsettings->printer conf. Not sure why it seems to fail to prompt yesterday immediately after 4.6.2 upgrade and logoff/on. Maybe I didn't reboot? Or maybe I was looking at the printer applet!

I just tried to add a new network printer via the printer applet in the tray and there I still don't get a prompt and still see the "client error forbidden". Exact steps: click printer applet, settings, printer configuration..., new printer, new network printer -- then error pops up.

Note You need to log in before you can comment on or make changes to this bug.