Bug 683629 - KWin doesn't start up in firstboot, error message: Configuration file "/root/.kde/share/config/kdedrc" not writable
KWin doesn't start up in firstboot, error message: Configuration file "/root/...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 692641 (view as bug list)
Depends On:
Blocks: F15Blocker-kde
  Show dependency treegraph
 
Reported: 2011-03-09 16:36 EST by E.Patton
Modified: 2011-10-10 23:28 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 14:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Welcome screen showing error (171.96 KB, image/png)
2011-03-10 14:28 EST, E.Patton
no flags Details
Log of avc error messages from /var/log/messages (8.55 KB, text/plain)
2011-03-10 14:44 EST, E.Patton
no flags Details

  None (edit)
Description E.Patton 2011-03-09 16:36:14 EST
Description of problem:

Error popup during display of Welcome screen following installation of F15 Alpha KDE x86_64 Live CD to KVM VM (F14).

quote
Configuration file "/root/.kde/share/config/kdedrc" not writable. Please contact your system administrator
end quote
Version-Release number of selected component (if applicable):

firstboot-1.117-2.fc15.86_64

Fedora-15-Alpha-x86_64-Live-KDE.iso


How reproducible:

Unknown - occurred immediately following installation.

Steps to Reproduce:
1.(Speculative). Boot VM off Live CD ISO. 
2.Immediately the desktop is displayed, select install to hard drive.
3.Install, re-boot and error is displayed as the Welcome screen is displayed
  
Actual results:

Error popup is displayed.

Expected results:

No popup, standard Welcome screen displayed.

Additional info:

Screenshot attached.
Comment 1 E.Patton 2011-03-09 16:37:58 EST
I should have noted that other than having to dismiss the popup, no other ill effects were observed. The installed VM is running just fine at the moment.
Comment 2 Martin Gracik 2011-03-10 06:59:37 EST
Firstboot does not do anything with that file. I think this error message is from kwin.

Also, you didn't attach any screenshot.
Comment 3 Kevin Kofler 2011-03-10 07:08:49 EST
Hmmm, is SELinux blocking this now? KWin as started (as root) by firstboot needs read-write access to at least /root/.kde/share/config/*, possibly all of /root/.kde and subdirectories. This worked fine until F14.
Comment 4 Rex Dieter 2011-03-10 09:30:05 EST
Fwiw, I just installed kde F15-alpha (x86_64) yesterday, didn't recall seeing any such popup.
Comment 5 Daniel Walsh 2011-03-10 11:00:19 EST
We need the avc message.  I have no idea what is being blocked.
Comment 6 Kevin Kofler 2011-03-10 12:15:04 EST
I'm not even 100% sure SELinux is involved here, it's just that I don't know what else would be blocking this.
Comment 7 Daniel Walsh 2011-03-10 12:45:20 EST
Can you run the install in permissive mode?
Comment 8 E.Patton 2011-03-10 14:28:00 EST
Created attachment 483544 [details]
Screenshot of Welcome screen showing error

Missing screenshot. Apologies!

avc logs to follwo
Comment 9 E.Patton 2011-03-10 14:44:10 EST
Created attachment 483549 [details]
Log of avc error messages from /var/log/messages

Requested avc messages.

I have captured audit.log if that would be of any use. Let me know and I will upload it.
Comment 10 Daniel Walsh 2011-03-10 14:54:04 EST
Well the latest policy has them dontaudited.  Most of those are caused by a bug in the kernel.

None related to kdm/kde though.
Comment 11 Jeremiah 2011-03-12 23:44:59 EST
This doesn't seem to be an issue with SELinux as I have created a respin with it disabled and ran into the same issue. When kwin is ran the missing .kde folder gets created for root and all the files that are not included in the kde-settings package end up getting created with just rw on user (root in this case) and nothing else. I'm guessing this is the issue but I have tested with my own kde-settings version with an included kdedrc file (pretty much empty) and it seems to fix the issue. So this seems to be an issue solely with KDE and what permissions it's config files get generated with.
Comment 12 Kevin Kofler 2011-03-12 23:51:23 EST
Well, it's normal that /root/.kde is only accessible by root. But there shouldn't be anything running as non-root and trying to access those files, the files of the relevant non-root user are supposed to be used instead.
Comment 13 Kevin Kofler 2011-03-12 23:54:40 EST
To anyone experiencing this: What file system is your /root on, i.e. what's the file system of your / partition (or /root if it's separate)?
Comment 14 Jeremiah 2011-03-13 01:15:54 EST
I think you mis-read me or I typed wrong, nothing non-root (or running not as root) should be trying to access roots .kde folder, but root "group" should have at least read privileges, on the file no? Right now it's 600. In that case shouldn't all the files kde-settings share the same privileges? Maybe it going away for me was a fluke.
Comment 15 Jeremiah 2011-03-13 01:16:28 EST
I'm running ext4
Comment 16 E.Patton 2011-03-13 05:13:06 EDT
/root is running on ext4/LVM. 

I accepted the installer defaults for a 32GB disk (provided by KVM)
Comment 17 Kevin Kofler 2011-03-13 11:43:57 EDT
> but root "group" should have at least read privileges, on the file no?

No. Settings are per user, not per group.
Comment 18 Martin Gracik 2011-03-21 07:34:56 EDT
Can this issue have anything to do with firstboot not using the gtk-oxygen theme?
Comment 19 Rex Dieter 2011-03-21 07:46:24 EDT
Unlikely, but possible I guess.
Comment 20 Martin Gracik 2011-03-21 09:21:11 EDT
Well, If I run firstboot from within the started desktop, the window decorations are OK, but when it's run as a systemd service, they are not. And firstboot does not do anything special, just runs Xorg and kwin, so I have no idea what else could cause this.
Comment 21 Rex Dieter 2011-03-21 09:28:24 EDT
The lack of theming (or not) is a separate issue to *this* bug. :)
Comment 22 Martin Gracik 2011-04-12 04:09:42 EDT
Related bug#692641
Comment 23 Martin Gracik 2011-04-12 04:47:49 EDT
Is it possible that the selinux relabeling happens _after_ firstboot is run, causing files having wrong context during firstboot, but everything is OK later?
Comment 24 Kevin Kofler 2011-04-12 10:14:31 EDT
*** Bug 692641 has been marked as a duplicate of this bug. ***
Comment 25 Adam Williamson 2011-04-15 15:25:48 EDT
Discussed at 2011-04-15 blocker review meeting. We can sort of stretch the criteria "# In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account" and/or "# In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login (see Blocker_Bug_FAQ) " to cover this; it's a bit of a stretch but we'll go with it for now. We may re-evaluate later if this turns out to be hard to fix...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 E.Patton 2011-04-21 16:15:38 EDT
Just to note that I did not experience the issue when I installed the Beta KDE (x86_64) live CD into the same VM as was used for the original issue.
Comment 27 Adam Williamson 2011-04-29 13:27:20 EDT
KDE team, can you take a look at this and decide if anything needs doing here? It's an open release blocker but we're not sure where it needs to go. Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Rex Dieter 2011-04-29 14:18:29 EDT
Installed f15-beta kde to vm (virt-manager/kvm), cannot reproduce.  firstboot started up fine (oxygen-gtk themed and all).
Comment 29 Danishka Navin 2011-10-10 23:28:31 EDT
I can see the same error on most of KDE apps in my Fedora 15 based remix.
It was in Fedora 14 based remix but i did not report it.

Once I click "OK" button in the error message, it wont appear again

Note You need to log in before you can comment on or make changes to this bug.