Bug 683720 - [abrt] Zim-0.50-1.fc14: pageindex.py:292:get_treepath:AssertionError: BUG: could not find path in pagelist
[abrt] Zim-0.50-1.fc14: pageindex.py:292:get_treepath:AssertionError: BUG: co...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:4555512f
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-10 01:43 EST by Giuseppe Fiorentino
Modified: 2011-12-16 05:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 05:12:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.07 KB, text/plain)
2011-03-10 01:43 EST, Giuseppe Fiorentino
no flags Details

  None (edit)
Description Giuseppe Fiorentino 2011-03-10 01:43:09 EST
abrt version: 1.1.17
architecture: i686
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.11-83.fc14.i686
package: Zim-0.50-1.fc14
reason: pageindex.py:292:get_treepath:AssertionError: BUG: could not find path in pagelist
release: Fedora release 14 (Laughlin)
time: 1299739260
uid: 500

backtrace
-----
pageindex.py:292:get_treepath:AssertionError: BUG: could not find path in pagelist

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 127, in on_changed
    treepath = self.get_treepath(path)
  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 292, in get_treepath
    assert False, 'BUG: could not find path in pagelist'
AssertionError: BUG: could not find path in pagelist

Local variables in innermost frame:
paths: [<IndexPath: interventi>, <IndexPath: interventi:147>]
parent: None
i: 10
k: (10,)
iter: <PageTreeIter, (10,), software>
self: <PageTreeStore object at 0x9712f7c (zim+gui+pageindex+PageTreeStore at 0x97566b0)>
p: <IndexPath: software>
reverse_cache: {<IndexPath: 147>: (0,), <IndexPath: PROGETTI>: (7,), <IndexPath: NOTE>: (6,), <IndexPath: DA FARE>: (3,), <IndexPath: hardware>: (4,), <IndexPath: RACCOGLITORE>: (8,), <IndexPath: CHKLIST>: (2,), <IndexPath: Calendar>: (1,), <IndexPath: software>: (10,), <IndexPath: INTERVENTI>: (5,), <IndexPath: RUBRICA>: (9,)}
path: <IndexPath: interventi>
treepath: ()

How to reproduce
-----
1.creare una nuova pagina
2.creare delle sottopagine nel namespace appena creato
3.rinominare il namespace creato al passo 1
Comment 1 Giuseppe Fiorentino 2011-03-10 01:43:12 EST
Created attachment 483372 [details]
File: backtrace
Comment 2 Robin Lee 2011-03-10 04:46:20 EST
Sorry, I can't reproduce it with your steps. Can you make it more detailed?
Comment 3 Eric Reitmaier 2011-03-22 11:11:26 EDT
Package: Zim-0.50-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Creating a new sub page.
2. Browsing around
3.


Comment
-----
Don't know if the steps above caused it.

Note You need to log in before you can comment on or make changes to this bug.