Bug 68377 - random generator not initialised properly?
random generator not initialised properly?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 12:27 EDT by iwi
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 12:27:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description iwi 2002-07-09 12:27:37 EDT
From the "start" section of /etc/rc.d/init.d/random

        action $"Initializing random number generator: " /bin/true
        chmod 600 $random_seed
        dd if=/dev/urandom of=$random_seed count=1 bs=512 2>/dev/null

I could be mistaken, but it appears to me that the input and output of dd are
the wrong way round for this to actually feed any entropy into the random number
generator.
Comment 1 iwi 2002-07-12 09:56:36 EDT
Closing this myself, as reporter.  This is not a bug.

I hadn't read the script carefully enough: it is a previous line that
initialises the random generator ("cat /var/tmp/random-seed >/dev/urandom").

Sorry to take your time.

Note You need to log in before you can comment on or make changes to this bug.