Bug 683835 - Random failure to unlock additional encrypted file systems
Random failure to unlock additional encrypted file systems
Status: CLOSED DUPLICATE of bug 678927
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-10 08:21 EST by Bruno Wolff III
Modified: 2011-03-25 14:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-25 14:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2011-03-10 08:21:25 EST
Description of problem:
I am seeing failure on some boots (maybe %50) where when it gets to the point where it needs to unlock addition file systems (e.g. /home), there is a long pause (maybe a minute) and then when the boot continues there are a lot of failures because the file systems haven't been unlocked. When there is no pause, things work as expected.
These addition file systems use the same passphrase as the root filesystem.

Version-Release number of selected component (if applicable):
systemd-20-1.fc15.i686

How reproducible:
Something on the order of 50%.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bruno Wolff III 2011-03-21 09:21:34 EDT
Some discussion in bug 678927 has talked about this issue as well.
I am not sure this is really a beta blocker because there is an easy work around. (The probability of success is high enough that it only takes a couple of reboots on average to get a good one.) I would think this is a nice to have for beta in any case.
Comment 2 Bruno Wolff III 2011-03-23 12:56:53 EDT
Starting yesterday morning one of my machines starting having this failure on every boot (or I have become very unlucky). That machine has /var on a separate partition and I have reverted rsyslog. I'll be testing this some more tonight to see if there is any change with further updates.
Comment 3 Bruno Wolff III 2011-03-24 09:09:50 EDT
This morning the machine is mounting encrypted devices during the boot process again. (I don't know that the random failures are fixed, just that at least once it booted OK.)
Comment 4 Bruno Wolff III 2011-03-24 11:21:49 EDT
It seems to be back to about %50 again. After trying to reboot again this moring it took a few tries to get past mounting additional encrypted file systems.
Comment 5 Adam Williamson 2011-03-25 14:34:33 EDT

*** This bug has been marked as a duplicate of bug 678927 ***

Note You need to log in before you can comment on or make changes to this bug.