Bug 683855 - gtk unthemed (ugly) when gnome-themes-standard not present
gtk unthemed (ugly) when gnome-themes-standard not present
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-themes-standard (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cosimo Cecchi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Blocker/F15FinalBlocker F15Blocker-kde F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-03-10 09:13 EST by Rex Dieter
Modified: 2013-04-30 18:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 19:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Specfile patch (1.69 KB, patch)
2011-03-18 19:35 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Rex Dieter 2011-03-10 09:13:22 EST
Unsure if this belongs here (gnome-themes-standard) or against gtk2/gtk3, but as of F15-alpha, the only pkg in the distro that provides /etc/gtk-2.0/gtkrc (and simililarly /etc/gkt-3.0/settings.ini) is gnome-themes-standard which is not a required dependendency for gtk2, gtk3 respectively.

So, systems without gnome-themes-standard installed, like any non-gnome spin, end up with ugly anaconda, firstboot (and others possibly).

Options off the top of my head (not necessarily mutually exclusive):
1.  gtk2, gtk3 packages include dependencies on *something* that provides a default/sane /etc/gtk-2.0/gtkrc and /etc/gtk-3.0/settings.ini, respectively
2.  provide some mechanism to be able to switch system gtk theming defaults that doesn't involve file/pkg conflicts
3.  <insert better idea here>
Comment 1 Kevin Kofler 2011-03-10 12:13:47 EST
And dragging in gnome-themes-standard as is is not a good idea because that drags in several unwanted dependencies which are not required for GTK+ to work.
Comment 2 Kevin Kofler 2011-03-18 19:35:13 EDT
Created attachment 486339 [details]
Specfile patch

Would the attached patch to the specfile be an acceptable solution?

This moves the GTK+ config files to the GTK+ theme subpackages. Those subpackages are required by gnome-themes-standard, so any installs which get the config files now will still get them dragged in. But with the change, it is enough to ship adwaita-gtk3-theme on a spin to get GTK+ 3 Adwaita-themed.

(FWIW, the gtk-icon-theme-name, gtk-button-images and gtk-menu-images settings should be mostly irrelevant, they will most likely get overridden through xsettings anyway, at least xsettings-kde does that. Only places like firstboot see them at all.)
Comment 3 Christoph Wickert 2011-03-21 13:11:09 EDT
As a result of bug 675509 the theme was split similar to Kevin's proposal, so I wonder if this is still a problem.
Comment 4 Kevin Kofler 2011-03-22 05:59:32 EDT
Yes. Check my patch in my proposal carefully, it is a followup to the changes from bug #675509. It moves the default GTK+ config files into the adwaita-gtk[23]-theme subpackages introduced by the fix for bug #675509.
Comment 5 Kevin Kofler 2011-03-24 22:41:55 EDT
Ping? Is the specfile patch I attached in comment #2 acceptable?
Comment 6 Fedora Update System 2011-03-28 14:22:57 EDT
gnome-themes-standard-2.91.93-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-themes-standard-2.91.93-2.fc15
Comment 7 Kevin Kofler 2011-03-28 18:02:46 EDT
This "fix" is very wrong!

Dragging in gnome-themes-standard from adwaita-cursor-theme defeats the very purpose of the adwaita-cursor-theme split. This is not acceptable.
Comment 8 Kevin Kofler 2011-03-28 18:03:54 EDT
See also the discussion in bug 675509.
Comment 9 Fedora Update System 2011-03-28 23:31:35 EDT
Package gnome-themes-standard-2.91.93-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-themes-standard-2.91.93-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-themes-standard-2.91.93-3.fc15
then log in and leave karma (feedback).
Comment 10 Kevin Kofler 2011-03-29 11:51:02 EDT
Uh no, gnome-themes-standard-2.91.93-3.fc15 doesn't fix this issue. (The broken "fix" got reverted, but no working one was applied.)

What do you think of my suggested fix from comment #2?
Comment 11 Cosimo Cecchi 2011-03-29 12:06:36 EDT
Kevin, now you're mistaken; your patch was applied indeed. See the spec file at http://pkgs.fedoraproject.org/gitweb/?p=gnome-themes-standard.git;a=tree;h=refs/heads/f15/master;hb=refs/heads/f15/master
Comment 12 Kevin Kofler 2011-03-29 13:15:39 EDT
Oh, indeed it's there, I still can't find the commit that made the change, but it's there. :-)

But you will have to file a new update request because the one you edited got unpushed due to bad karma.
Comment 14 Kevin Kofler 2011-04-05 19:02:37 EDT
gnome-themes-standard-3.0.0-1.fc15, which includes this fix (among other things) got pushed to F15 stable today and will be included in the F15 Beta.

Note You need to log in before you can comment on or make changes to this bug.