This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 68386 - total screwup during firstboot
total screwup during firstboot
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 14:35 EDT by James Manning
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-13 18:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages - check the lines like "No devices detected" coming from XF86 :/ (24.07 KB, text/plain)
2002-07-09 14:38 EDT, James Manning
no flags Details
generated XF86Config that firstboot had such a problem with (3.29 KB, text/plain)
2002-07-09 14:40 EDT, James Manning
no flags Details
even after an Xconfigurator attempt, failed X startup (10.39 KB, text/plain)
2002-07-09 14:48 EDT, James Manning
no flags Details

  None (edit)
Description James Manning 2002-07-09 14:35:38 EDT
not really sure where to even start with this.  this is the firstboot after the
bug #68384 test setting didn't work, but i picked a valid res/color combo
(16-bit, 1600x1200) for this card (Matrox Millennium G250, using G200 as the
card selection) and monitor (ViewSonic E790-3) - auto-probing failed because
there's a Cybex SwitchView KVM switch involved (and it would appear to be
breaking the DDC probing, but I don't get why the card selection didn't work,
but I digress) - works fine when I picked those settings and the same machine
boots over to 7.3

anyway, on first boot things are going find til it says it's starting firstboot.
 The screen flashes a few times (like X is attempting to start) and then I get,
on vt7, a curses-based screen that I can barely describe (sshots of curses-based
stuff would be ideal).  It's basically the normal blue background, an empty
white/gray box with 2 "buttons" of "<Yes>" and "<No>"  but 1) the drop-shadowing
and border stuff is all broken, it's all G's with accents on top (dunno the
unicode char) and 2) whatever "button" is not selected has its characters
replaced with weird stuff (like <Yes> becomes something like R|FCS but the
characters have accents and stuff - very weird.

I'd imagine this traces back to the newt/minislang stuff notting's been on
(iirc) in terms of the menu looking like it does, but why I'm starting at a menu
(broken as it is) in my vt7 instead of a graphical Red Hat Setup Agent (or
whatever it's called) is the "source" bug.

Tons of entries in /var/log/messages relating to the failed X stuff, so I'll
attach it.
Comment 1 James Manning 2002-07-09 14:38:49 EDT
Created attachment 64424 [details]
/var/log/messages - check the lines like "No devices detected" coming from XF86 :/
Comment 2 James Manning 2002-07-09 14:40:11 EDT
since it's failing to find any X devices, I'll attach the XF86config that is
generated as well, in case mharris needs to handle this
Comment 3 James Manning 2002-07-09 14:40:55 EDT
Created attachment 64425 [details]
generated XF86Config that firstboot had such a problem with
Comment 4 James Manning 2002-07-09 14:48:26 EDT
Created attachment 64426 [details]
even after an Xconfigurator attempt, failed X startup
Comment 5 Brent Fox 2002-07-09 17:51:15 EDT
Who closed this bug report as 'notabug'?  I didn't even get a chance to look at
it...
Comment 6 James Manning 2002-07-09 22:10:42 EDT
me, because 95% of the bug is the broken X stuff and that's because I was 
config'ing wrong (picking the wrong card).  Now, the bizarre menu that pops up 
when X is broken is still a possible target, but that's all about unicode and 
the newt/minislang stuff, so it's not really worth rehashing here imho
Comment 7 Warren Togami 2002-07-10 08:18:51 EDT
Hold on there, I had a total screwup during firstboot too and my X configuration
was perfectly working.  When it reached firstboot it displayed some error
messages and the screen flashed a few times trying to run X.  Immediately after
that the error messages were visible for a few seconds then I was unable to read
them when X and gdm ran (cannot SHIFT-PGUP after changing back to VT1).

This is an "Everything" install of Limbo if that means anything.  I will attempt
more testing of this tomorrow.

In the mean time, please re-open.
Comment 8 Brent Fox 2002-07-13 18:09:38 EDT
warren, maybe you should file a new report since your problem seems a little
different than the original reporter's.
Comment 9 Warren Togami 2002-07-13 18:30:51 EDT
I totally can't reproduce figure out how to reproduce my problem.  I'm
reinstalling Limbo on three boxes right now to attempt to figure it out.
Comment 10 James Manning 2002-07-13 18:43:07 EDT
warren - in case it helps, one thing i found out is that in this weird
situations you can get multiple X instances running at once, and depending on
which one you're sitting on, you can get diff visible behaviors.  Specifically,
the firstboot graphical stuff will attempt (in Limbo the firstboot fails to
require metacity, which Brent has fixed already for the next beta) on vt7 but
what may *also* be happening is a kdm/gdm/whatever on your vt8.

So:

1) go ahead and do a new bugzilla entry - it'll be better on all fronts, if for
no other reason than the fact that I've cluttered this one up with all kinds of
useless junk :)

2) ctl-alt-f{7,8,1,etc} on first post-install boot to make sure you know what's
going on with each virtual terminal - it made things a lot better for me :)

Note You need to log in before you can comment on or make changes to this bug.