Bug 68393 - RFE: package name consistancy (dateconfig and serviceconf)
Summary: RFE: package name consistancy (dateconfig and serviceconf)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: dateconfig (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-09 21:17 UTC by Dan Burcaw
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 21:20:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Burcaw 2002-07-09 21:17:15 UTC
Both dateconfig and serviceconf (and perhaps other packages) provide
redhat-config-* modules.  Why not rename these packages redhat-config-date
and -services, etc. to reflect this? This level of consistancy is something
that Red Hat often lacks, and it would be nice to see it! :-)

Comment 1 Brent Fox 2002-07-10 19:54:54 UTC
I agree.  I suggest you file a separate bug report for serviceconf, though.  It
is maintainted by someone else who will most likely not see this bug report
since it can only be filed against one component. 

I plan to rename dateconfig to redhat-config-date.

I also maintain ksconfig, and I plan to rename it to redhat-config-kickstart.

Comment 2 Dan Burcaw 2002-07-10 20:05:47 UTC
Great! I opened a seperate bug for serviceconf. Out of curiosity,
can I expect this name change within the current cycle of rawhide
development? Or is this someting slated for a future cycle?


Comment 3 Brent Fox 2002-07-10 20:15:51 UTC
I'm going to check with the guys in release engineering to see how much pain
would be involved with changing the names in the current cycle.  The way I see
it, the change needs to be done, and waiting until a future cycle just amplifies
the pain.  We'll see what they say.  ;)

Comment 4 Brent Fox 2002-07-10 20:23:15 UTC
They said it was ok for this release, so I'll try to get this done today.

Comment 5 Dan Burcaw 2002-07-10 20:34:31 UTC
Excellent! This pleases me greatly.  Now if I can push your
collegue (serviceconf and maybe printconf) in this direction :-)


Comment 6 Brent Fox 2002-07-10 22:06:52 UTC
Ok, the name switch is done.  I will push the new packages through the build
system tomorrow morning and they should appear in Rawhide sometime soon.  I
think the other packages should be renamed as well.  Just keep nagging them.  ;)

I'm going to close this report now since the work is done on my end.  Thanks for
your report and thanks for doing the Limbo.

Comment 7 Brent Fox 2002-07-11 15:35:03 UTC
The packages have been run through the build system now.


Note You need to log in before you can comment on or make changes to this bug.