Bug 683950 - startx log - xkbcomp reports: Internal error: Could not resolve keysym XF86TouchpadOn
Summary: startx log - xkbcomp reports: Internal error: Could not resolve keysym XF86...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkb-utils
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-10 18:32 UTC by jurek.bajor
Modified: 2018-04-11 08:38 UTC (History)
3 users (show)

Fixed In Version: libX11-1.3.4-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-02 22:51:24 UTC


Attachments (Terms of Use)
startx.log (70.19 KB, text/plain)
2011-03-18 11:02 UTC, jurek.bajor
no flags Details
dmesg (64.56 KB, text/plain)
2011-03-18 11:04 UTC, jurek.bajor
no flags Details
Xorg.0.log (49.14 KB, text/plain)
2011-03-18 11:05 UTC, jurek.bajor
no flags Details

Description jurek.bajor 2011-03-10 18:32:11 UTC
Description of problem:
GNOME desktop.
$ startx >& .startx.log'

$ cat .startx.log
...
X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: x86-06 2.6.32-71.14.1.el6.x86_64 
Current Operating System: Linux localhost.localdomain 2.6.35.11-83.fc14.i686 #1 
SMP Mon Feb 7 07:04:18 UTC 2011 i686
Kernel command line: ro root=UUID=405dfc83-0215-412f-aff4-4f76ac1f5e19 noiswmd L
ANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
Build Date: 09 February 2011  05:44:54PM
Build ID: xorg-x11-server 1.9.4-1.fc14 
Current version of pixman: 0.18.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 10 19:04:19 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86TouchpadOn
> Internal error:   Could not resolve keysym XF86TouchpadOff
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86TouchpadOn
> Internal error:   Could not resolve keysym XF86TouchpadOff
Errors from xkbcomp are not fatal to the X server
...
Internal error:   Could not resolve keysym XF86TouchpadOn
Internal error:   Could not resolve keysym XF86TouchpadOff
Applet requires SELinux be enabled to run.
...

Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-7.5-1.fc14.i686

How reproducible:
as above

Steps to Reproduce:
1. as above
2.
3.
  
Actual results:
as above

Expected results:


Additional info:

Comment 1 Matěj Cepl 2011-03-18 00:16:40 UTC
(In reply to comment #0)
> How reproducible:
> as above
> 
> Actual results:
> as above

These are actually not helpful ... how many times out of how many attempts this happened? Are you able to reproduce the issue at will?

Also, what are the actual results of the error? Does touchpad works for you? Is there something missing in its capabilities?

Using information from https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm, could we get the following items attached to this issue report as separate uncompressed attachments, please?

 * any file in /etc/X11/xorg.conf.d and /etc/X11/xorg.conf itself (if you have any),
 * /var/log/XOrg.0.log
 * /proc/bus/input/devices
 * output of running evtest (from the evtest package) against its device file (see in /proc/bus/input/devices which one is which)

Thank you for helping to make Fedora awesome!

Comment 2 jurek.bajor 2011-03-18 11:02:20 UTC
Created attachment 486206 [details]
startx.log

Comment 3 jurek.bajor 2011-03-18 11:04:36 UTC
Created attachment 486207 [details]
dmesg

Comment 4 jurek.bajor 2011-03-18 11:05:23 UTC
Created attachment 486208 [details]
Xorg.0.log

Comment 5 jurek.bajor 2011-03-18 11:14:02 UTC
It is Lenovo Thinkpad R61i.
It has a TrackPoint and 3-key control for simulating mouse keys (left, middle,
right).
It has an external USB mouse.

No user problems with keyboard or mouse.
But errors as captured in ~/.startx.log , every time on startx (with GNOME).
They must be relatively recent (since few months back).

$ ls /etc/X11/xorg.conf
ls: cannot access /etc/X11/xorg.conf: No such file or directory
$ ls /etc/X11/xorg.conf.d/
$
 
$ cat /proc/bus/input/devices
I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
U: Uniq=
H: Handlers=event0 
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
U: Uniq=
H: Handlers=kbd event1 
B: EV=3
B: KEY=4000 0 0 0 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2 
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0011 Vendor=0001 Product=0001 Version=ab54
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input3
U: Uniq=
H: Handlers=kbd event3 
B: EV=120013
B: KEY=4 2000000 3803078 f800d001 feffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=000a Version=0000
N: Name="TPPS/2 IBM TrackPoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input4
U: Uniq=
H: Handlers=mouse0 event4 
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0003 Vendor=0458 Product=003a Version=0110
N: Name="Genius Optical Mouse"
P: Phys=usb-0000:00:1a.1-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/input/input5
U: Uniq=
H: Handlers=mouse1 event5 
B: EV=17
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
U: Uniq=
H: Handlers=kbd event6 
B: EV=3
B: KEY=3e000b 0 0 0 0 0 0 0

I: Bus=0019 Vendor=17aa Product=5054 Version=4101
N: Name="ThinkPad Extra Buttons"
P: Phys=thinkpad_acpi/input0
S: Sysfs=/devices/platform/thinkpad_acpi/input/input7
U: Uniq=
H: Handlers=kbd event7 rfkill 
B: EV=33
B: KEY=18840000 0 0 100000 0 0 0 1501b 2005 0 1104000 e0000 0 0 0
B: MSC=10
B: SW=8

$ 

Also, see attachments.
JB

Comment 6 Fedora Update System 2011-03-22 01:48:28 UTC
libX11-1.3.4-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libX11-1.3.4-4.fc14

Comment 7 Fedora Update System 2011-04-02 22:51:19 UTC
libX11-1.3.4-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.