Bug 68397 - ISOLINUX fails to locale CD-ROM, fails to boot.
ISOLINUX fails to locale CD-ROM, fails to boot.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 17:37 EDT by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 03:18:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-07-09 17:37:46 EDT
I've received beta3 CDs yesterday and just tried booting the installed, but
couldn't.

I get the following messages:

ISOLINUX 1.75 2002-06-14 isolinux: Loading spec packet failed, trying to wing it...
isolinux: Failed to locate CD-ROM device; boot failed.

I have an IDE CD drive (the only IDE device I have, the HD is SCSI). Here is
what dmesg (in 7.2) shows on my drive:

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX3: IDE controller on PCI bus 00 dev 39
PIIX3: chipset revision 0
PIIX3: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
hda: NEC CD-ROM DRIVE:282, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Comment 1 Jeremy Katz 2002-07-10 01:55:20 EDT
More important -- what type of motherboard do you have?  Also, if you burn the
image at http://people.redhat.com/~katzj/debugiso.bin (won't actually let you
continue the install, but should give more debugging messages about where
isolinux gets hung up), what sort of output do you get?
Comment 2 Aleksey Nogin 2002-07-10 13:19:06 EDT
> More important -- what type of motherboard do you have?

How do I find out?

Here is what lspci says:

00:00.0 Host bridge: Intel Corp. 440FX - 82441FX PMC [Natoma] (rev 02)
00:06.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 01)
00:07.0 ISA bridge: Intel Corp. 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
00:07.1 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
00:07.2 USB Controller: Intel Corp. 82371SB PIIX3 USB [Natoma/Triton II] (rev 01)
00:09.0 SCSI storage controller: Adaptec AIC-7880U
00:0b.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II]

> Also, if you burn the image ...

I do not have an easy access to a burner.
Comment 3 scottbeverly 2002-07-10 18:32:03 EDT
I too am having the same problem on an UNknown motherboard with the Limbo CDs I
got in the mail.  I reported the same as not working with Jeremy's first
isolinux test image.  This box is an old Gateway PPro 200, with an old AMI Bios
v1.000something-er-other.

I downloaded the iso Jeremy mentions in this bug report.  While the regular beta
CDs (v7.3.92) do boot but give the error mentioned in this bug, the debugiso.bin
image is not even recognized by this problem system it is ignored and the system
boots from the hard drive. Oh, and I did boot that image in another machine, so
I know that my burn was at least somewhat working.

Is there anything else I can do to help, short of knowing what kind of MB is in
this thing?
Comment 4 Aleksey Nogin 2002-07-10 19:13:00 EDT
In my case it's an AmiBios too. Namely, AmiBios Verion 1.00.01.DI0 (C) 1992...
Comment 5 Jeremy Katz 2002-07-10 23:12:06 EDT
It seems to be common on really old AMI BIOSes.  You might check for an update
(there may be one).  I'm really reluctant to make CD 2 bootable also because it
makes things more confusing for support and from a documentation perspective. 
Especially as there have always been machines which haven't booted from the CD,
we're just switching which those are now to some older machines as a trade-off
for more drivers available for CD installs
Comment 6 scottbeverly 2002-07-15 18:40:37 EDT
Ok, sounds like the right thing to do (besides now my laptop will boot from the
CD and I like that :).  Would it be possible to make sure we still have a boot
image that we can either put on floppy or easily burn to a CD(like the old boot
CD)?  Sorry, I haven't even looked to see if that is already the plan, so if
that is the case I'll crawl back into my hole and leave you alone. ;)

Thanks for your help, 
Scott...
Comment 7 Jeremy Katz 2002-07-15 19:23:05 EDT
There's always images/boot.img on the CD which will work just fine for CD
installs.  You can even easily burn it to CD by sticking it in a directory and
running

mkisofs -b boot.img -o ../bootcd.iso .

And then you have a 1.44 meg CD to burn.  There's also still
dosutils/autoboot/cdboot.img which is the old 2.88 meg image used which was used
for the CD boots, but I'm not 100% certain that it will stick around
Comment 8 Jeremy Katz 2002-12-29 03:18:43 EST
If this isn't fixed with isolinux 2.00 as used in Phoebe, it's going to need to
be reported upstream and fixed there.

Note You need to log in before you can comment on or make changes to this bug.