Bug 68416 - /etc/inputrc doesn't match behaviour of xterm
/etc/inputrc doesn't match behaviour of xterm
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: setup (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 21:26 EDT by Michael Schwendt
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 21:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-09 21:26:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
The escape sequences generated by xterm for the Pos1/Home & End keys don't match
those configured in /etc/inputrc.

$ rpm -q setup
setup-2.5.13-3

$ xterm -v
XFree86 4.2.0(165)

Pos1/Home gives: ^[[7~
End gives: ^[[8~

But /etc/inputrc contains:

"\e[1~": beginning-of-line
"\e[4~": end-of-line

I had to change it to

"\e[7~": beginning-of-line
"\e[8~": end-of-line

in my local ~/.inputrc (as if it was for old rxvt) to work correctly.
Comment 1 Michael Schwendt 2002-07-09 22:00:35 EDT
D'oh! The cause of it were my own overrides via X resources, because xterm and
rxvt never had been consistent with regard to this.

Note You need to log in before you can comment on or make changes to this bug.