Bug 684283 - TypeError: value is of the wrong type for this column
TypeError: value is of the wrong type for this column
Status: CLOSED DUPLICATE of bug 682543
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
anaconda_trace_hash:2cd71e5db836fbabe...
:
: 684302 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-11 12:02 EST by Paul W. Frields
Modified: 2014-09-30 19:39 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-22 03:58:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (589.14 KB, text/plain)
2011-03-11 12:02 EST, Paul W. Frields
no flags Details
Attached traceback automatically from anaconda. (583.94 KB, text/plain)
2011-03-15 14:43 EDT, Paul W. Frields
no flags Details
Attached traceback automatically from anaconda. (1.46 MB, text/plain)
2011-03-19 12:59 EDT, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (1.02 MB, text/plain)
2011-03-21 21:33 EDT, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (703.39 KB, text/plain)
2011-03-23 03:43 EDT, Michael Schwendt
no flags Details
Attached traceback automatically from anaconda. (1.02 MB, text/plain)
2011-03-24 14:13 EDT, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (467.56 KB, text/plain)
2011-03-25 07:58 EDT, Pavel Šimerda (pavlix)
no flags Details
Attached traceback automatically from anaconda. (575.93 KB, text/plain)
2011-03-25 12:43 EDT, info@kobaltwit.be
no flags Details
Attached traceback automatically from anaconda. (1.83 MB, text/plain)
2011-03-25 17:48 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Paul W. Frields 2011-03-11 12:02:26 EST
The following was filed automatically by anaconda:
anaconda 15.22 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 607, in __setitem__
    self.model.set_value(self.iter, key, value)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1002, in populate
    self.tree[iter]['Size (MB)'] = vg.freeSpace
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1840, in getScreen
    self.populate(initial = 1)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1338, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
TypeError: value is of the wrong type for this column
Comment 1 Paul W. Frields 2011-03-11 12:02:31 EST
Created attachment 483777 [details]
Attached traceback automatically from anaconda.
Comment 2 Paul W. Frields 2011-03-11 12:09:39 EST
I'm doing a fresh install using jlaska's new boot.iso from this morning (15.22-1).  After selecting basic storage devices, and defaults for intro options, then using Custom disk layout, the "Examining storage devices" notice appears, followed by the above traceback.
Comment 3 Chris Lumens 2011-03-11 13:11:28 EST
*** Bug 684302 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2011-03-11 13:33:54 EST
Ales - my guess for why we are seeing this issue (and the other similar one, also assigned to you) is that python or pygtk was allowing us to get away with some implicit type conversion where the model said a column was a string but we could toss an int in without running str() on it first.  And now that's changed.

I can't see that we've changed either the gtk code or the types of the things we're storing in these models.

So the two fix options are we change the models to have the column be an int type, or we call str() on things before putting them into the model.  The first option seems to be nicer - we might as well be storing in the model the actual things, rather than a type converted form of them.

Feel free to reassign back to a-m-l if you don't want to work on this.  I just assigned this one to you since you already had the related one.
Comment 5 Ales Kozumplik 2011-03-14 04:19:02 EDT
The related issue is bug 682543.
Comment 6 Paul W. Frields 2011-03-15 14:43:13 EDT
Created attachment 485579 [details]
Attached traceback automatically from anaconda.
Comment 7 James Laska 2011-03-15 14:53:19 EDT
(In reply to comment #5)
> The related issue is bug 682543.

That linked issue has now been reassigned to gtk.  Should this bug follow, or are there anaconda changes needed here?
Comment 8 Paul W. Frields 2011-03-15 14:59:38 EDT
Steps I used to reproduce:

1. Started with bare metal (laptop) that has LVM partitioning setup.  Fair number of LVs, but nothing too exotic.

2. Boot from a copy of the pxelinux flavor vmlinuz + initrd.img.  I used one jlaska produced for testing anaconda-15.22-1, but the same error happened in 15.20.1-1.

3. Choose basic storage devices, and defaults for everything, until disk setup screen.

4. Choose Custom layout, and the "Examining storage" dialog comes up.

5. After a short time, poof, traceback.
Comment 9 Paul W. Frields 2011-03-15 15:01:07 EDT
By the way, vmlinuz + initrd.img were stored on my hard disk's /boot partition.  I booted into them from GRUB.
Comment 10 Ales Kozumplik 2011-03-16 03:43:18 EDT
> That linked issue has now been reassigned to gtk.  Should this bug follow, or
> are there anaconda changes needed here?

James,

If this is fixed on the GTK side (the right thing to do), we will be able to close this as dupe. If not I want to keep this bug to track one more place that needs mending.
Comment 11 Adam Williamson 2011-03-18 13:19:26 EDT
Discussed at the 2011-03-18 blocker review meeting. We're worried about this one, but so far not enough data to be sure it's a blocker. Exactly what condition is needed to trigger this bug? Is it some particular content in the column in question (disk size?), or some number of entries in that column, or something like that? Thanks.

CCing mclasen: Matthias, this is another issue caused by 682543. Just to make you aware this is a potential beta blocker and we'd definitely like to see pygobject fixed. thanks!
Comment 12 Clyde E. Kunkel 2011-03-19 12:59:24 EDT
Created attachment 486390 [details]
Attached traceback automatically from anaconda.
Comment 13 Clyde E. Kunkel 2011-03-19 13:05:24 EDT
Booted desktop nightly 20110318.

Started install to hard disk.
Selected custom partitioning
traceback occurred during (end of?) storage device scan.

System has intel bios raid 10 device serving as PV for numerous lvs all of which are seen in the live session.
Comment 14 Clyde E. Kunkel 2011-03-21 21:33:02 EDT
Created attachment 486714 [details]
Attached traceback automatically from anaconda.
Comment 15 Clyde E. Kunkel 2011-03-21 21:38:49 EDT
This time JLaska's custom boot.iso.  Same steps as Comment 13
Comment 16 Ales Kozumplik 2011-03-22 03:58:12 EDT

*** This bug has been marked as a duplicate of bug 682543 ***
Comment 17 Michael Schwendt 2011-03-23 03:43:37 EDT
Created attachment 486972 [details]
Attached traceback automatically from anaconda.
Comment 18 Clyde E. Kunkel 2011-03-24 14:13:05 EDT
Created attachment 487403 [details]
Attached traceback automatically from anaconda.
Comment 19 Pavel Šimerda (pavlix) 2011-03-25 07:58:50 EDT
Created attachment 487542 [details]
Attached traceback automatically from anaconda.
Comment 20 info@kobaltwit.be 2011-03-25 12:43:44 EDT
Created attachment 487601 [details]
Attached traceback automatically from anaconda.
Comment 21 Pavel Šimerda (pavlix) 2011-03-25 12:50:29 EDT
For me it happened when installing fedora15/x86_64 through boot.fedoraproject.org. I'd be happy to test F15.
Comment 22 Ian Pilcher 2011-03-25 17:48:14 EDT
Created attachment 487685 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.