Bug 68432 - VNC Server conflicts with DCOPserver
Summary: VNC Server conflicts with DCOPserver
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-10 07:15 UTC by Richard Palm
Modified: 2007-04-18 16:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 09:48:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps -x > ps.txt (3.37 KB, text/plain)
2002-07-10 07:17 UTC, Richard Palm
no flags Details

Description Richard Palm 2002-07-10 07:15:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
System running KDE.  When the VNC Server is started and is running, the kde 
console monitor shows errors.
Example:  When starting Kedit the following error is shown:   DCOP 
communications error (kdesktop_lock) and Kedit doesn't start.
               Other processes don't start and the same error appears.
               The VNC client works in all functions.

If you set the server to start on boot and don't login, the VNC server starts 
and everything works correctly on the client.  If you login, everything works 
correct on the console and now the VNC client has DCOP communications errors.

We upgraded to version 7.3 and have the same results.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run desktop in kde
2. Start vncserver
3. desktop has DCOP communications error (kdestop_lock)
	

Additional info:

Can't run both desktop console and vncserver at the same time

Comment 1 Richard Palm 2002-07-10 07:17:15 UTC
Created attachment 64544 [details]
ps -x > ps.txt

Comment 2 Tim Waugh 2002-07-10 07:26:59 UTC
The 'vncserver' program starts a VNC session using your own defaults, and so if you run KDE  
by default the VNC session also will. (This was a requested feature.)  
  
You can change this by altering your ~/.vnc/xstartup script to launch whichever session you  
prefer.  The default used to be to just run xterm and (I think) twm.  
  
Unfortunately, KDE no longer allows a user to run more than one KDE session at a time.  In  
my opinion this is a KDE bug.  
 
(If you have a good suggestion for altering VNC's behaviour to work around this KDE bug, 
please let me know!)

Comment 3 Richard Palm 2002-07-12 23:18:06 UTC
SuSE version 8.0 running Kde3 works correctly

Comment 4 Richard Palm 2002-07-18 17:16:01 UTC
Had some success.  Changed "/root/.vnc/xstartup" based on other scripts (startkde, kde)

--------------xstartup-----------------------------------------------------
#!/bin/sh

#  Red Hat ..............
# exec /etc/X11/xinit/xinitrc  "removed from script"

#  added the following commands
xrdb $HOME/.Xrousrces
xsetroot -solid grey
kdeinit
kwrapper ksmserver --restore
#Clean up
kdeinit_shutdown
dcopserver_shutdown
#------------------------------------------------------------

Comment 5 Ryan Dill 2003-06-19 17:21:54 UTC
Same problem here with redhat-release-7.3-1, kdebase-3.0.3-0.7.2 and
vnc-3.3.3r2-28.2.

Note that KDE considers this to be a bug specific to RedHat's custom version of
the 'startkde' script. See http://bugs.kde.org/show_bug.cgi?id=40153 for details.

I have successfully used console KDE and VNC KDE together simultaneously by
copying 'startkde' to 'startkde-vnc' and modifying 'startkde-vnc' to comment out
the /tmp/.ICE-unix/* removal, as noted in comment #6 of the KDE bug report. My
$HOME/.vnc/xstartup file then calls startkde-vnc instead of startkde.

Is RedHat's clean of the /tmp/.ICE-unix/ directory really necessary? Should the
behaviour be changed to something similar to what comment #7 mentions, instead?


Comment 6 Ryan Dill 2003-06-30 20:30:14 UTC
From what I can see, this problem is not limited to VNC. I've been able to
reproduce it with regular XDMCP logins as well. i.e.:

- Start a console KDE login on the machine in question
- From some remote machine, attempt an XDMCP login to the same machine (Exceed
from a Microsoft Windows machine, for example), choosing a KDE login

After this, attempting to run any DCOP applications on the original console KDE
login will fail, because the XDMCP login calls "startkde", wiping the
/tmp/.ICE-unix files being used by the first (console) KDE session.

Can anyone confirm what I'm seeing?


Comment 7 Ngo Than 2003-07-03 09:48:41 UTC
oh yes, it's a bug in startkde, which is fixed in rawhide now. I don't know if i
should make errata for this issue. For workaround, please comment out the
/tmp/.ICE-unix/* removal.



Note You need to log in before you can comment on or make changes to this bug.