Bug 68435 - Want alt-sysrq-dump key combo
Summary: Want alt-sysrq-dump key combo
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: netdump (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ingo Molnar
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 67608
TreeView+ depends on / blocked
 
Reported: 2002-07-10 07:42 UTC by Johan Walles
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-05 08:04:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johan Walles 2002-07-10 07:42:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020412
Debian/0.9.9-6

Description of problem:
I have successfully installed and tested (using the crash.o module) the netdump
client (0.6.6-1) on our RHAS server.  However, when the server actually crashes
"for real", no netdump gets sent :-(.

This may of course be because the kernel is too fucked up to be able to send a
crash dump, but it *could* depend on that the kernel just hasn't been able to
detect that it has crashed.  In case 2, I'd like to be able to explicitly tell
the kernel that it has crashed.

Unless you have a better idea, an alt-sysrq key combo for doing just that would
be great.  When crashed, our server does respond to alt-sysrq-'b'oot, but it
seems not to want to do any alt-sysrq-'u'nmounting.  So, a magic sysrq key combo
could help us out (or not...).

Comment 1 Johan Walles 2002-07-11 08:01:20 UTC
Our kernel actually responds to Alt-SysRq-* when crashed, and it does send the
result codes to the netdump server.  Thus, having this implemented has a great
chance of actually helping fixing bug 67608 (kernel hang).


Comment 2 Michael K. Johnson 2002-07-12 14:06:34 UTC
Agreed, a dump-now sysrq combo would be convenient.

Comment 3 Ingo Molnar 2003-07-05 08:04:31 UTC
This feature has been implemented for the next enterprise product.

Comment 4 ginnie nuckles 2004-06-03 14:53:10 UTC
Hello .. can you tell me what this dump-now switch is ?? I cannot get 
ALt-Sysrq-m to work at all it just does nothing .. I can do Alt-Sysrq-
t .. so I know that the Alt-Sysrq function works anyhow .. please 
adivse ..we are running this is currently being tested on ES 3.0 
v2 ..thanks 

Comment 5 Dave Anderson 2004-06-03 15:07:01 UTC
It's Alt-sysrq-c, which will force an oops upon receiving the
keycode.


Note You need to log in before you can comment on or make changes to this bug.