Bug 684476 - kdebase-workspace requires gpsd
kdebase-workspace requires gpsd
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: depchain
  Show dependency treegraph
 
Reported: 2011-03-12 17:04 EST by Christoph Wickert
Modified: 2011-03-17 08:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 08:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-03-12 17:04:55 EST
Description of problem:
kdebase-workspace requires gpsd (libgps.so.19). I don't think this makes sense as only very few people have a GPS device. plasma-geolocation-gps or all geolocation plasmas should go into package a separate package in KDE 4.6.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.5.5-2.fc14
Comment 1 Kevin Kofler 2011-03-12 17:13:13 EST
As you specified in your report, this is not a new dependency in 4.6, so I don't think this should block the 4.6 update. I'm taking it off the kde-4.6 tracker.
Comment 2 Christoph Wickert 2011-03-12 17:24:59 EST
Do as you like. I agree it's not a blocker for the 4.6 update, but I think this is a good time to fix this.
Comment 3 Kevin Kofler 2011-03-12 17:34:57 EST
Let's decide at the KDE SIG meeting on Tuesday what to do about this.
Comment 4 Rex Dieter 2011-03-15 10:15:29 EDT
Looks like these would need to be split out to accomplish this:

%{_kde4_libdir}/kde4/plasma-geolocation-gps.so
%{_kde4_datadir}/kde4/services/plasma-geolocation-gps.desktop

That said, the fact that gpsd is < 1mb in size, not sure if the effort here is worth the minimal savings and increased complexity from another subpkg.
Comment 5 Ngo Than 2011-03-17 08:02:25 EDT
the size pf gpsp is minimal < 1mb, i don't think it's worth splitting it in subpackage.

Note You need to log in before you can comment on or make changes to this bug.