Bug 684509 - Non-regression test t/perlcritic.t fails with recent versions of Perl::Crititc
Non-regression test t/perlcritic.t fails with recent versions of Perl::Crititc
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-13 03:51 EDT by Raphaël Hertzog
Modified: 2011-07-25 20:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raphaël Hertzog 2011-03-13 03:51:49 EDT
publican fails to build because the test suite fails. Here's the log message:
[...]
t/910.publican.Users_Guide.t .. ok

#   Failed test 'Test::Perl::Critic for "blib/script/publican"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/script/publican":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 717, column 9.  (Severity: 5)

#   Failed test 'Test::Perl::Critic for "blib/lib/Publican/Builder.pm"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/lib/Publican/Builder.pm":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 1678, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 1827, column 13.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 2042, column 5.  (Severity: 5)

#   Failed test 'Test::Perl::Critic for "blib/lib/Publican/CreateBook.pm"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/lib/Publican/CreateBook.pm":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 375, column 9.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 402, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 413, column 5.  (Severity: 5)

#   Failed test 'Test::Perl::Critic for "blib/lib/Publican/CreateBrand.pm"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/lib/Publican/CreateBrand.pm":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 126, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 244, column 9.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 312, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 363, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 369, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 423, column 9.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 529, column 5.  (Severity: 5)

#   Failed test 'Test::Perl::Critic for "blib/lib/Publican/Translate.pm"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/lib/Publican/Translate.pm":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 193, column 5.  (Severity: 5)
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 689, column 5.  (Severity: 5)

#   Failed test 'Test::Perl::Critic for "blib/lib/Publican/XmlClean.pm"'
#   at /usr/share/perl5/Test/Perl/Critic.pm line 110.
# 
# Perl::Critic found these violations in "blib/lib/Publican/XmlClean.pm":
# [InputOutput::RequireEncodingWithUTF8Layer] I/O layer ":utf8" used at line 653, column 9.  (Severity: 5)
# Looks like you failed 6 tests of 10.
t/perlcritic.t ................ 
Dubious, test returned 6 (wstat 1536, 0x600)
Failed 6/10 subtests 
t/pod-coverage.t .............. ok
t/pod.t ....................... ok

Test Summary Report
-------------------
t/perlcritic.t              (Wstat: 1536 Tests: 10 Failed: 6)
  Failed tests:  2-5, 7, 10
  Non-zero exit status: 6
Files=10, Tests=70, 178 wallclock secs ( 0.26 usr  0.06 sys + 181.68 cusr  3.28 csys = 185.28 CPU)
Result: FAIL
Failed 1/10 test programs. 6/70 subtests failed.


Version-Release number of selected component (if applicable):
perl 5.10.1-17
libperl-critic-perl 1.113-1
libtest-perl-critic-perl 1.02-1


Additional info:
Originally reported in Debian at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=616696
Comment 1 Jeff Fearn 2011-03-13 07:09:08 EDT
Switched UTF8 to new usage.

Committed revision 1732.
Comment 2 Jeff Fearn 2011-07-04 08:02:27 EDT
back ported fix to branches/publican-2x

Committed revision 1798.

Note You need to log in before you can comment on or make changes to this bug.