Bug 684526 - FTBFS - ocaml unpackaged files
Summary: FTBFS - ocaml unpackaged files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: brltty
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1443907
TreeView+ depends on / blocked
 
Reported: 2011-03-13 10:33 UTC by Zenon Panoussis
Modified: 2017-04-20 08:53 UTC (History)
3 users (show)

Fixed In Version: brltty-4.1-7.el6
Doc Type: Bug Fix
Doc Text:
Previously the build of brltty could fail on ocaml unpackaged files error. This happened only if ocaml was preinstalled in build root. The --disable-caml-bindings switch was added to configure and the build of caml bindings is now explicitli disabled.
Clone Of:
: 702724 1443907 (view as bug list)
Environment:
Last Closed: 2012-09-05 09:13:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1231 normal SHIPPED_LIVE brltty bug fix update 2012-09-05 13:12:14 UTC

Description Zenon Panoussis 2011-03-13 10:33:23 UTC
Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/rpmbuild/BUILDROOT/brltty-4.1-6.el6.x86_64
error: Installed (but unpackaged) file(s) found:
   /usr/lib64/ocaml/brlapi/META
   /usr/lib64/ocaml/brlapi/brlapi.cma
   /usr/lib64/ocaml/brlapi/brlapi.cmi
   /usr/lib64/ocaml/brlapi/brlapi.cmxa
   /usr/lib64/ocaml/brlapi/brlapi.mli
   /usr/lib64/ocaml/brlapi/dllbrlapi_stubs.so
   /usr/lib64/ocaml/brlapi/libbrlapi_stubs.a

This is caused by configure at 

checking for ocamlc... ocamlc
checking for ocamlmklib... ocamlmklib
configure: OCaml version is 3.11.2
configure: OCaml library path is /usr/lib64/ocaml
checking for ocamlopt... ocamlopt
checking ocamlopt version... ok
checking for ocamlc.opt... ocamlc.opt
checking ocamlc.opt version... ok
checking for ocamlopt.opt... ocamlopt.opt
checking ocamlc.opt version... ok
checking platform... Unix
checking for ocamlfind... ocamlfind

Possible solutions (in increasing order of ugliness):

1. Add --disable-caml-bindings to %configure.
2. Package the files and add appropriate ocaml BuildRequires.
3. Delete the files if found during %install.
4. Add appropriate ocaml BuildConflicts.

Comment 2 RHEL Product and Program Management 2011-03-13 10:57:35 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Jaroslav Škarvada 2011-05-06 18:02:52 UTC
Thanks for report.

It happens only if ocaml is pre-installed into build root, it builds OK in clean build root (e.g. in mock).

The --disable-caml-bindings should be used.

Comment 4 Jaroslav Škarvada 2011-05-06 18:23:04 UTC
Cloned to Fedora rawhide as bug 702724.

Comment 7 Jaroslav Škarvada 2012-07-27 08:23:34 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously the build of brltty could fail on ocaml unpackaged files error. This happened only if ocaml was preinstalled in build root. The --disable-caml-bindings switch was added to configure and the build of caml bindings is now explicitli disabled.

Comment 12 errata-xmlrpc 2012-09-05 09:13:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1231.html


Note You need to log in before you can comment on or make changes to this bug.