Bug 684565 - Gnome2 - Unable to mount - Authentication is required
Gnome2 - Unable to mount - Authentication is required
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
: 684904 (view as bug list)
Depends On:
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-03-13 10:03 EDT by Flóki Pálsson
Modified: 2011-03-15 12:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-15 12:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2011-03-13 10:03:15 EDT
Description of problem:
After changing to Standard with desktop-effects then it is not possible to mount disks or partition which are not in root file system.

Version-Release number of selected component (if applicable):
nautilus-2.91.91-1.fc15.x86_64

How reproducible:
Always 

Steps to Reproduce:
1. Change to Standard ( Gnome2) with desktop-effects
2. In Nautilus Click on partition or Device  
3.
  
Actual results:
Window 
Unable to mount Fedora-13-x86_64
Authentication is required

Expected results:
To see window for root password

Additional info:
Works ok in Gnome-shell
Comment 1 Tomáš Bžatek 2011-03-14 08:48:42 EDT
This seems to me like a PolicyKit agent is not running, not able to handle password request. 

Can you try running /usr/libexec/polkit-gnome-authentication-agent-1 and see what happens?
Comment 2 Flóki Pálsson 2011-03-14 14:26:07 EDT
>Can you try running /usr/libexec/polkit-gnome-authentication-agent-1 and see
>what happens?
It just hangs there with no result
$ /usr/libexec/polkit-gnome-authentication-agent-1
Comment 3 Tomáš Bžatek 2011-03-15 06:21:11 EDT
(In reply to comment #2)
> >Can you try running /usr/libexec/polkit-gnome-authentication-agent-1 and see
> >what happens?
> It just hangs there with no result
> $ /usr/libexec/polkit-gnome-authentication-agent-1
Yeah, that's correct :-) But you should be able to authenticate now (from Nautilus). That's what I wanted you to check.
Comment 4 Bastien Nocera 2011-03-15 08:58:31 EDT
*** Bug 684904 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2011-03-15 09:01:36 EDT
desktop-effects should be retired. It won't switch session types properly
(leaving a number of things like polkit agent, applets, etc.) not running when
switching to fallback, and is deprecated by the control-center's info panel.
Comment 6 Bastien Nocera 2011-03-15 12:25:12 EDT
Added the obsoletes to control-center, though the build might fail, due to some packages not being in the buildroot.
Comment 7 Owen Taylor 2011-03-15 12:42:14 EDT
desktop-effects marked dead in package git, blocked from f15 and f16.

Note You need to log in before you can comment on or make changes to this bug.