Bug 684659 - URLGrabError exception when running preupgrade (F14 -> F15a, post boot)
URLGrabError exception when running preupgrade (F14 -> F15a, post boot)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 03:07 EDT by Yaniv Kaul
Modified: 2013-07-03 22:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-24 14:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2011-03-14 03:07:00 EDT
Description of problem:
After running preupgrade and rebooting the host, the upgrade does not run. It exits with an exception (see full backtrace in additional info): 
mirror.py:283:_get_mirror:URLGrabError: [Errno 256] No more mirrors to try.

A nicer exit message would benefit the poor user, who is clueless as to why his upgrade did not work. One cannot see that it actually failed, only when looking at /var/log/messages:
Mar 13 18:07:08 ykaul preupgrade-gtk.py: abrt: detected unhandled Python exception in /usr/share/preupgrade/preupgrade-gtk.py

(Note: tested from within RH office network, so one would assume mirrors should work well. Guess they didn't).

Version-Release number of selected component (if applicable):
preupgrade-1.1.8-1.fc14.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
mirror.py:283:_get_mirror:URLGrabError: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 259, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 278, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 500, in main_preupgrade
    stage2file = self.pu.retrieve_non_critical_files()
  File "/usr/lib/python2.7/site-packages/preupgrade/__init__.py", line 571, in retrieve_non_critical_files
    self._retrieve_file(self.mainimage, targetdir, reserve_space=extra_space)
  File "/usr/lib/python2.7/site-packages/preupgrade/__init__.py", line 451, in _retrieve_file
    tmp = self.instgrab.urlopen(fileinfo)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 413, in urlopen
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 386, in _mirror_try
    mirrorchoice = self._get_mirror(gr)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 283, in _get_mirror
    raise URLGrabError(256, _('No more mirrors to try.'))
URLGrabError: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
self: <urlgrabber.mirror.MirrorGroup instance at 0x39e2b00>
gr: <urlgrabber.mirror.GrabRequest instance at 0x3e8ccf8>
Comment 1 Richard S. Hendershot 2011-03-20 02:03:18 EDT
this also happens with preupgrade-cli: preupgrade-1.1.8-1.fc14.noarch
Not tested from within RH network...   ;)


...
/boot/upgrade/initrd.img checksum OK
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 327, in <module>
    pu.main(release)
  File "/usr/share/preupgrade/preupgrade-cli.py", line 223, in main
    stage2file = self.retrieve_non_critical_files()
  File "/usr/lib/python2.7/site-packages/preupgrade/__init__.py", line 571, in retrieve_non_critical_files
    self._retrieve_file(self.mainimage, targetdir, reserve_space=extra_space)
  File "/usr/lib/python2.7/site-packages/preupgrade/__init__.py", line 451, in _retrieve_file
    tmp = self.instgrab.urlopen(fileinfo)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 413, in urlopen
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 386, in _mirror_try
    mirrorchoice = self._get_mirror(gr)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 283, in _get_mirror
    raise URLGrabError(256, _('No more mirrors to try.'))
urlgrabber.grabber.URLGrabError: [Errno 256] No more mirrors to try.
Comment 2 Christoph Höger 2011-03-28 10:09:46 EDT
I had the same error here. But it seems to be fixed with the latest build. 

preupgrade-1.1.9-1.fc14 worked just fine.

(might be by accident, though)
Comment 3 Michael J. Chudobiak 2011-06-24 14:42:51 EDT
I had the same problem, and 1.1.9 also fixed it.

Closing bug...

- Mike

Note You need to log in before you can comment on or make changes to this bug.