Bug 684758 - [Pineview] Xorg crash on waltop tablet
[Pineview] Xorg crash on waltop tablet
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-wacom (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-14 08:47 EDT by Lukas Bezdicka
Modified: 2011-04-05 17:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-drv-wacom-0.10.99-1.20110315.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of Xorg & lsusb -v of tablet (47.79 KB, text/plain)
2011-03-14 08:47 EDT, Lukas Bezdicka
no flags Details
Xorg log (36.47 KB, text/plain)
2011-03-14 08:56 EDT, Lukas Bezdicka
no flags Details
Xlog after building wacom driver from git (41.00 KB, text/plain)
2011-03-14 11:14 EDT, Lukas Bezdicka
no flags Details

  None (edit)
Description Lukas Bezdicka 2011-03-14 08:47:30 EDT
Created attachment 484162 [details]
backtrace of Xorg & lsusb -v of tablet

Xorg crashes on start when detecting waltop tablet.
Comment 1 Lukas Bezdicka 2011-03-14 08:56:56 EDT
Created attachment 484168 [details]
Xorg log
Comment 2 Lukas Bezdicka 2011-03-14 11:14:18 EDT
Created attachment 484217 [details]
Xlog after building wacom driver from git

building from git fixes the crash, so seems to be fixed in upstream.
But there is remaining problem with not realy working wacom driver.
Comment 3 Fedora Update System 2011-03-15 18:15:00 EDT
xorg-x11-drv-wacom-0.10.99-1.20110315.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-wacom-0.10.99-1.20110315.fc15
Comment 4 Lukas Bezdicka 2011-04-04 07:26:39 EDT
bug seems to be back on F15-Beta-TC1
Comment 5 Christopher Aillon 2011-04-05 14:07:44 EDT
Lukas, that's because package updates require positive feedback in order to be pushed out.  There was an update link supplied in comment 3.  In the future, if you would help us out by providing feedback on updates, it would help us get package fixes to stay.

We got someone to provide feedback just now, so I've gone ahead and marked this as stable, so will appear soon.

I'm proposing this for F15Beta based on the following Alpha criterion:

15. ...a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention.
Comment 6 Lukas Bezdicka 2011-04-05 14:19:11 EDT
sorry my bad. I have to remember that whining about bugs isn't enough :)
Comment 7 Fedora Update System 2011-04-05 17:40:13 EDT
xorg-x11-drv-wacom-0.10.99-1.20110315.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.