Bug 684765 - Plugins not being deleted from server after purge (in HA?)
Plugins not being deleted from server after purge (in HA?)
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: John Sanda
Corey Welton
:
Depends On:
Blocks: rhq4 gwt-plugins
  Show dependency treegraph
 
Reported: 2011-03-14 09:02 EDT by Corey Welton
Modified: 2011-10-04 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-03-14 09:02:07 EDT
Description of problem:
After deleting and purging plugins, the files are not being physically removed from the server.  This is in an HA configuration, but that might actually be a red herring.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Install two RHQ servers in an HA configuration
2.  Administration > Plugins
3.  Delete the IRC agent plugin
4.  Purge the deleted plugin
5.  Observe that the plugin has disappeared from the UI.
6.  Wait some time and view the plugins directory on both servers
  
Actual results:
The plugin remains on the filesystem(s)

Expected results:
The plugin gets deleted.

Additional info:
As noted, I'm not sure whether or not this is an artifact of the HA configuration. But plugins have gotten deleted before just fine.
Comment 1 John Mazzitelli 2011-03-25 14:31:07 EDT
i think john sanda just fixed this (or something close to this) recently.

assigning to john to close if appropriate or to comment if its still a problem
Comment 2 John Sanda 2011-03-25 14:34:58 EDT
I am moving this to ON_QA because I believe that the fix for bug 683545 addresses this as well.
Comment 3 Mike Foley 2011-05-02 14:37:22 EDT
deleted and purged plugins, they remain deleted.  rhq 4.0 rc2
Comment 4 Corey Welton 2011-05-23 21:09:18 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.