Bug 684785 - /etc/profile.d/cvs.csh uses non-tcsh syntax
Summary: /etc/profile.d/cvs.csh uses non-tcsh syntax
Keywords:
Status: CLOSED DUPLICATE of bug 671145
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cvs
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
high
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-14 13:50 UTC by Petr Pisar
Modified: 2011-03-14 13:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 671003
Environment:
Last Closed: 2011-03-14 13:55:17 UTC


Attachments (Terms of Use)
/etc/profile.d/cvs.csh (92 bytes, application/x-csh)
2011-03-14 13:53 UTC, Petr Pisar
no flags Details

Description Petr Pisar 2011-03-14 13:50:58 UTC
+++ This bug was initially created as a clone of Bug #671003 +++

Description of problem:

  Here's the content of the csh profile /etc/profile.d/cvs.csh:

    # change default from rsh to ssh for cvs command
    setenv CVS_RSH "${CVS_RSH-ssh}"

  This is not valid tcsh syntax.  This kind of variable substitution
  is only valid in POSIX shells.

  Right now, this bug does not result in an error when starting tcsh, but
  only because current tcsh versions ignore that line for the simple reason
  that it's missing a newline.  However, the upcoming tcsh 6.18.00 will NOT
  ignore that last line anymore and a syntax error will occur.

  The correct syntax for csh and tcsh is

    if ( "$?CVS_RSH" == 0 ) setenv CVS_RSH

  I hope this can be fixed soon.  And, please add a newline since otherwise
  the line will never be executed with the current tcsh 6.17.00.


Thanks,
Corinna

--- Additional comment from vinschen@redhat.com on 2011-01-19 21:36:08 GMT ---

Oops, I missed to set CVS_RSH to ssh.  So, here the *corrected*
correct syntax for csh and tcsh:

    if ( "$?CVS_RSH" == 0 ) setenv CVS_RSH ssh

---

cvs-1.11.23-11.el6_0.1.x86_64 in RHEL-6.1 is affected too. The CVS_RSH variable is not set on log-in into csh because missing new line causes silent ignorance of the command.

As we are adding CSH support into RHEL-5 (bug #571559), we should make sure RHEL-6 provides the same experience.

Comment 1 Petr Pisar 2011-03-14 13:53:31 UTC
Created attachment 484191 [details]
/etc/profile.d/cvs.csh

Fixed content of cvs.csh profile script.

Comment 2 Petr Pisar 2011-03-14 13:55:17 UTC

*** This bug has been marked as a duplicate of bug 671145 ***


Note You need to log in before you can comment on or make changes to this bug.