Bug 684792 - switch upstream to ipxe?
switch upstream to ipxe?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpxe (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 785972 (view as bug list)
Depends On: 804826
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 10:14 EDT by Paolo Bonzini
Modified: 2013-01-09 18:39 EST (History)
6 users (show)

See Also:
Fixed In Version: ipxe-20120328-1.gitaac9718.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 23:34:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to the spec file (4.55 KB, patch)
2011-03-15 09:51 EDT, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Paolo Bonzini 2011-03-14 10:14:00 EDT
Description of problem:
gPXE development is basically stalled.  The attached patch switches upstream to a snapshot of iPXE from 2001-03-13.

Version-Release number of selected component (if applicable):
1.0.1-4

Additional info:
One important blocker: upstream QEMU officially is still using gpxe.  The change also needs to be concerted with the qemu package, which references gpxe roms.
Comment 1 Glauber Costa 2011-03-14 12:00:11 EDT
In the past, we lead qemu on newer ROMS, and not the other way around. We first showed this was viable, then upstream switched. Arguably it is not the default way of doing things in fedora, but worked well in the past. We did had, however, pre-communication with maintainership, and the commitment that qemu would switch, had the move been successful.

I think we could apply the same formula here. Specially considering that
* ipxe is much more similar to gpxe than gpxe was to etherboot
* we already have all the infrastructure to pick roms from either etherboot and gpxe, we could add ipxe to the list with minimum disrupt.
Comment 2 Paolo Bonzini 2011-03-15 09:51:22 EDT
Created attachment 484540 [details]
patch to the spec file
Comment 3 Fedora Admin XMLRPC Client 2011-04-04 16:37:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Justin M. Forbes 2011-04-18 13:29:14 EDT
This is planned for the F16 release cycle.
Comment 5 Daniel Berrange 2012-03-19 08:00:32 EDT
*** Bug 785972 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Berrange 2012-03-19 08:01:13 EDT
Well we missed F16, and it is a bit late in F17 cycle to switch BIOS. So F18 it is.
Comment 7 Daniel Berrange 2012-03-19 10:37:21 EDT
I'm working on new packages for ipxe:

  http://berrange.fedorapeople.org/review/ipxe/

will submit a new review ticket, once I get past the current build errors with iPxe

  http://lists.ipxe.org/pipermail/ipxe-devel/2012-March/001289.html
Comment 8 Daniel Berrange 2012-03-19 17:01:15 EDT
Review bug for ipxe

https://bugzilla.redhat.com/show_bug.cgi?id=804826
Comment 9 Fedora Update System 2012-03-29 04:56:24 EDT
ipxe-20120328-1.gitaac9718.fc17, qemu-1.0-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-4242/ipxe-20120328-1.gitaac9718.fc17,qemu-1.0-10.fc17
Comment 10 Fedora Update System 2012-03-29 22:57:29 EDT
Package ipxe-20120328-1.gitaac9718.fc17, qemu-1.0-10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipxe-20120328-1.gitaac9718.fc17 qemu-1.0-10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4242/ipxe-20120328-1.gitaac9718.fc17,qemu-1.0-10.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-04-02 13:46:42 EDT
Package ipxe-20120328-1.gitaac9718.fc17, qemu-1.0-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ipxe-20120328-1.gitaac9718.fc17 qemu-1.0-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4242/ipxe-20120328-1.gitaac9718.fc17,qemu-1.0-11.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-04-11 23:34:03 EDT
ipxe-20120328-1.gitaac9718.fc17, qemu-1.0-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.