Bug 6848 - bus error with Netscape after upgrading to 4.7
bus error with Netscape after upgrading to 4.7
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-09 05:54 EST by harrij
Modified: 2014-03-16 22:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-17 16:09:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harrij 1999-11-09 05:54:32 EST
Netscape Communicator 4.7 started to crash with bus error
after I upgraded to 4.7 from 4.51. It crashes right after I
run it so it's probably not connected to the earlier Java
bus error.
Comment 1 Bill Nottingham 1999-11-09 11:21:59 EST
Ok, what does 'chkfontpath --list' and 'rpm -qa | grep netscape' say?

------- Additional Comments From   11/09/99 14:04 -------
They say:

[harri@cloudbuster harri]$ /usr/sbin/chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/share/fonts/default/Type1
8: /usr/X11R6/lib/X11/fonts/Truetype
9: /usr/X11R6/lib/X11/fonts/100dpi
10: /usr/X11R6/lib/X11/fonts/75dpi
[harri@cloudbuster harri]$ rpm -qa | grep netscape
netscape-communicator-4.7-1.1
netscape-common-4.7-1.1
[harri@cloudbuster harri]$
Comment 2 kie 1999-11-17 14:18:59 EST
I get a bus-error every time i try lo add a link in composer with NS 4.7 across
several plattforms (tested 5.2, 6.0, 6.1), all having the newest RPMs
Comment 3 Harvey Stein 1999-11-25 12:42:59 EST
I have the same problem after trying to upgrade from 4.61-12us to 4.7-1.1us.
I followed the advice re: chkfontpath but that didn't help.  Using strace &
ltrace it seems that netscape is trying to open librvcore.so but failing to
do so.  It looks in /lib/i586, /lib, /usr/lib/i586, and /usr/lib, but it's
located in /usr/local/rvplayer5.0.  After adding it to LD_LIBRARY_PATH, it
manages to load librvcore.so, but than fails trying to find libm.so.5 (which
is in /usr/i486-linux-libc5/lib).  I tried adding the latter path to
LD_LIBRARY_PATH, but that doesn't work, presumably because then it starts
grabbing stuff from there that it shouldn't.  Maybe this will help you guys
to trace down the problem...  Uninstalling or appropriately reinstalling
the rvplayer might be a work around, but I haven't tried that yet.
Comment 4 Harvey Stein 1999-11-25 13:52:59 EST
It seems to be an incompatibility btw netscape and the rvplayer I had installed.
I removed librvplayer.so from .netscape/plugins and now netscape doesn't give
a bus error when starting.  I'm entering this from netscape 4.7.  Could those
afflicted with this bug please try removing all traces of librvplayer.so &
librvcore.so from your system and see if netscape starts working.  Don't
just remove it from from .netscape/plugins because netscape also looks at other
directories for plugins).  Please add a comment here as to whether or not this
fixes your problem.

NOTE - this is *not* a bug fix, it's just a work around.  We really need
netscape working with the rvplayer plugin.  Maybe a newer version of rvplayer
(if such exists) would help?
Comment 5 Bill Nottingham 1999-12-10 13:19:59 EST
The problem you're having is most likely that you're
using a libc5 realplayer, along with a glibc netscape.
This just won't work, period.

You'd need to use a glibc-2.x version of realplayer;
Real Audio has a version for their 5.0 version, or
you could use the alpha G2 player.
Comment 6 Bill Nottingham 1999-12-10 13:20:59 EST
(the adding a link crash in composer is known. There's no
real workaround available.)

Note You need to log in before you can comment on or make changes to this bug.